.NET website not working with ApplinX 8.1.2

We have a .NET website currently working with applinx 5.2.5. It was created in Visual Studio 2008, using a template provided by Doug Kelly. then we added our own aspx pages and invoke procedure paths in teh code behind. It works well with applinx 5.2.5. It is not an instant app.

We have installed applinx 8.1.2 and successfully mograted our application. We can debug our procedure paths from the new applinx designer. However we can’t get our .net website to work with the new applinx server. I have checked the configuration gx_appConfig.xml file, it has the correct IP and port number.

We have a login path, but it doesn’t even get to that, it fails on the call to gx_connect(), with the following error in the attached gxlog.txt file.

Are we missing something here? Is there a new class or library that is required for a .NET website to work with applinx 8.1.2?
gxlog.txt (5.54 KB)

Miguel,
You mentioned migrating from 5.2.5 but didn’t mention upgrading the web application (I mean the “update the existing web application” in the Web Application Manager). Did you?

Tanya

I can’t bring up the web application manager in the designer, the menu option for it is disabled. I have installed the Designer and the applinx .net framework in this machine. I can execute and debug paths in this application using the designer successfully.

As I mentioned my website is not an instant app. How can I upgrade my visual studio code? Is there a new DLL or assembly I need to use?

For instance, do I need new versions of GXFramework.dll and GXDotnet.dll?

don’t tell me I need to create a new web application with the new applinx template and add my aspx pages and cs files to it. that would be definitely not optimal.

Miguel, I can think of 3 reasons:

the eclipse is not set to the right Applinx installation directory (check in preferences->Applinx) - in that case set it to the right directory;

a license problem (see whether you have the right license in server properties -> license). Though this one seems a bit unlikely, but let’s check it anyway;

when installed the 8.1.2 for some reason the .net framework was missed. Make sure you have a .net directory under the applinx. If you don’t - install applinx again.

Let me know whether any of those helped.

Tanya

Hi Tanya,

I have tried setting the applinx installation directory in the preferences dialog, but it also requires the JDK and the Tomcat locations, what should I enter here? See the attched screenshot. Also see the attached Applinx Folder structure, it has 2 .net directories.


Hey Tanya I specified the C:\SoftwareAG folder for my applinx installation, to avoid conflicts with my applinx 5.2 which lives in C:\Program Files\Software AG.
However I reviewed the CTP_install.log file under C:\SoftwareAG\install\logs and found that it claims to have installed some things in C:\Program Files\Software AG.

See the attached files,
CTP_install.log (131 KB)

Miguel,

the jdk location and the tomcat should be in C:\Program Files\Software AG
try updating that in the preferences and see whether the upgrade existing application becomes available.

Tanya

Hi Tanya, a few of questions:

  1. Do you think it’s best to first uninstall my applinx 5.2 administrator and then install the Designer using c:\program files\Software AG as the installation folder? I mean, just to avoid any overlapping.

  2. Regarding the Tomcat folder, why do I need tomcat for the designer? Isn’t tomcat a component of the server? If so, do I need to have also the applinx server installed inthe same machine as the designer?

  3. In our environment we have a win 2003 server for the applinx server and we are using our desktops for development, so we need to have the designer in htem as well as visual studio 2008, is this technically feasible?

Hi Tanya,

The designer keeps rejecting my setting for the Tomcat location, and I do have it installed in C:\Program Files\Software AG\Tomcat, see the attached screenshot.

What is the validation expecting for this value? Is this to do with the fact that I don’t have the applinX server installed in this machine? See my previous post.

Miguel,

the tomcat installation path is just tomcat, without the cp8.0,

If that won’t help, lets try to reinstall applinX 8, this time make sure you chose the typical installation (uncheck the server, I understand you don’t need that part) and let’s see from there whether after the install you’ll have the upgrade existing application available.

Hope it helps.

Tanya

Hi Tanya,

I tried using C:\Program Files\Software AG\Tomcat as the tomcat path, the designer still complains it’s not valid, see the screen shot. I’ll try reinstalling now.

I’m wondering why does the Designer need a path to Tomcat. I noticed we have a Software AG Tomcat at the server too, and we’ve been told that we need it to run on port 2380 for the Visual Studio Add in. So we’re wondering why do we need a Tomcat instance in our development worksation.

I re-installed, using typical installation (except for the applinx server), and I’m still unable to set the tomcat path in the preferences in the Designer. See the attched screenshots.


We are also having this same problem. The option to Web Application Manager is disabled. I have read through this topic and the issue is very similar to ours. Miguel/Tanya - did you get this resolved? What is the resolution?

I should add that we installed 8.1 to a different directory - C:\Program Files\Software AG 8_1\ApplinX. I have checked the preferences and everything that Tanya suggested that Miguel check, and we seem to have all the components pointing to the correct directory.

Barb,

what solved Miguel’s problems was giving the correct paths to both the applinx installation and the tomcat in eclipse applinx preferences.
Your tomcat installation directory is
:\Documents and Settings\All Users\Application Data\Software AG\Tomcat

Tanya

Is there something the installation process or inputs need to change in order for this to work consistently for these users? Miguel indicates he re-installed and still had the problem - why did the install not put in the correct path? Was there something in the install options that they should have selected differently?

Hello
Please check your license file
is yes
if it is not don’t change it just get a new license from SAG
Sandu

Thanks Sandu. This solved our problem and is also something that Tanya had noted earlier on in this topic, but I wasn’t exactly sure what to look for in terms of licensing, until you pointed it out specifically.

Once we received a new license from SAG and reinstalled the software, the option to update the Web Application (“Web Application Manager”) was enabled.