Problem with SP2


today I installed SP2, but now I get the following error:

Error Number: 5005

Error Message: Not connected to Server (com.sabratec.applinx.common.runtime.GXBasicEntityInfo; Serializable incompatible with Externalizable)

I (re)started ApplinX server, Tomcat, Eclipse, but without success. I started a session manually in ApplinX manager and tried out f.e. a path and all worked.

Can anybody tell me, where I have to look or what I have to change or what I did wrong?


Hi Michael,

It seems that you haven’t updated one of the components.
When installing a new version you need to make sure that all components of ApplinX are now of the same version, so if the server is the clients should also be of the same version.


Hi Gadi,

this is my logfile. Perhaps you can see, if anything is missing.
What I did, was to run the .bat file.

install.hotfix.log (1.49 KB)

Did you also upgraded the web application?
You need to run the web application manager from the Eclipse and update the web application.

…now I did that.
But after all restarts I still get the same error message.

The problem is that your client application is missing the new ‘gxframework.jar’ and/or ‘gxbinaryclient.jar’ files.
The web application manager should have updated these in your web application, if it didn’t you can update them manually.

Thanks Gadi,
after a restart of Eclipse and a clean version of the application it now works.
Thanks again,