Not able to create flat file schema from SEF file

Hello Friends,

I am trying to create flat file schema for an ANSI X12, version 4010, transaction 214. To do this, using webMethods supplied flow service - wm.b2b.edi:createTemplateFromSEF. All the required parameter inputs were supplied and while executing the service, it throws error as below,

Could not run “createTemplateFromSEF”

com.wm.ff.parse.StorageException:[ISS.0085.9080] node name already in use.

I am using wM 6.1 and WmEDI package without other webMethods components. So, I cannot install schema from webMethods Admin page.

Also, I am using SEF files supplied by webMethods.

Parameter inputs are,

1). SEFfileName : \webMethods6\IntegrationServer\packages\WmEDI\pub\SEFS\X12\4010.sef

2). TransactionName : 214

3). TargetSchema : EDIX12:FFSchV4010214

4). TargetPackage : EDIVF

5). TargetDictionary : EDIX12:FFDictV4010214

6). OverwriteDictionary : True

Your help/suggestions would be greatly apprecaited.

Thanks,
Siva

com.wm.ff.parse.StorageException:[ISS.0085.9080] node name already in use.

Based on this error did you checked if this EDIFFSchema T214 already exists in any of your existing packages??

Check this advantage thread also…
https://advantage.webmethods.com/advantage?targChanId=kb_home&oid=1611828884

HTH,
RMG

Siva,
You can also use this service to determine if the schema or the dictionary you are trying to create already exists.

wm.b2b.edi.util:nodeExists

Shubhro

Hi Subhro,

      Thanks for your reply. Tried per your suggestion and this is what the result. Could you please provide more hint, if you can.

     Checked with executing the service - wm.b2b.edi.util:nodeExists. Looks like this service takes "Element" name i.e., like flow service, schema, trigger name as Input value and checks for its existance. This service has one input (service) and one output (status). 
          However, before executing wm.b2b.edi:createTemplateFromSEF, I need to create TargetSchema and Dictionary. So, if I provide these names as input to the service -wm.b2b.edi.util:nodeExists, I am getting Status as "true".
          Can you explain about this nodeExists, I cannot find documentation for this Built-In-Service in EDIModuleBISRefernce.pdf

Hi RMG,

   Thanks for your help. I checked advantage thread and modified file extension (sef) to uppercase and restarted IS. Unfortunately, did not work. 

Thanks,
Siva

Can you try by deleting the schema, but leaving the dictionary.

Shubhro

Shubhro, Thanks very much for your suggestion. It worked.

Lesson learned: Only dictionary should be created not schema, before invoking service - createTemplateFromSEF

Thanks to all replied to this thread.
Siva