Create EDI Template From SEF File error

When I run the service wm.b2b.edi:createTemplateFromSEF with all parameters it is giving following error:

com.wm.ff.parse.StorageException: [ISS.0085.9080] node name already in use.

Hello,
If you are trying to setup a schema for TN and Developer with a version and transaction type supported by WM using the EDI module, you can you the admin web page. On this page go to Solutions, EDI. When that page opens, go to Install EDI Document types. You use the three select boxes to install the needed information into TN and Be available under Developer. Good day.

Yemi Bedu

Malla,

Are you trying to create any custom schema?or standard EDI schema,if so please follow yemi’s comments above.

HTH,
RMG

Even after installing EDI Document types also getting same error.

My Objective is creating schema for edi 810(4010) from sef file.

Service used:-
wm.b2b.edi:createTemplateFromSEF

parameters:-
SEFfileName:C:\webMethods61\IntegrationServer\packages\WmFlatFile\pub\SEFS\X12\4010.SEF
transactionName:810
includeEnvelope:false
isBigDocTemplate:false
targetSchema:FlatFile:sefSh(blank schema)
targetPackage:Default
targetDictionary:FlatFile:schDic
overwriteDictionary:false
sourceDictionaries:

error on run:Could not run ‘sefFileSch’.
com.wm.ff.parse.StorageException: [ISS.0085.9080] node name already in use

Hello,
Your error is one that I got when I first started using webmethods. i thought I had to hand load the schema from the SEF. You do not have to do this. If you go through the admin web page you should be able to tell that you have the schema loaded, you will either be told it loaded succesfully or it is already loaded. in either case you can now find the schema information under “WmEDIforTN -> EDIFFSchema -> X12 -> 4010 -> T810”. Under here you can make a document type base on the schema for times when want to map against a visible strucutre. For that go to the schema path metioned before, click the “flat file structure” tab and then click the last icon in the upper left (as per 6.0.1 Developer) and it will create a document in the same folder. Good day.

Yemi Bedu

Malla.

Which version of IS/EDI are you using?If you are on IS6.x and above please follow yemi’s comments to load the EDI X124010 810 Standard Dictionary/Schema/documentType etc…

HTH,
RMG

Thanks Yemi/RMG
I am able to create schema using “Install EDI Document types”.

But I want to use wm.b2b.edi:createTemplateFromSEF
service and why/what is this error?

what is the significance of this service…

If you are able to install EDI doc types,you can ignore this service,since this was used by earlier version of WM for schemas customization or no templates on hand etc…

I get the following execption while running services “SEFParse” & " CreateTemplateFromSEF" in the “wm.b2b.edi” package.

java.util.No such element exception
I am trying to convert the sef file into template.

Pls help .I need to resolve this urgently.

Ur help would be appreciated.

Thanks & Regards
Amit

If you are able to create
FFSchema using “Install EDI Document types” using ISAdmin/EDI webpage then are you trying to create any custom template/Schema?

How is your loading SEF file structure looks like?please tell us what are you trying to do.

HTH,
RMG

Hello,
On this thread, please tell us the following:

  1. whether you are trying to load an SEF that came with webmethods.
  2. whether you obtained the SEF elsewhere.
  3. a. if you have not made changes to the file.
  4. b. if you have made changes to the file.
  5. or 1. b. what are the exact inputs passed to each available field for the service wm.b2b.edi:createTemplateFromSEF, as this is what is used under the previous given conditions.

For (1. a.) Then the solution is already outlined in previous posts on this thread.
For (2. or 1. b.) If you are getting a “node already exists” error, then you are trying to add something that already exists to the file system for Developer and TN.

I am not sure for other errors, as I found I was putting efforts in that where not needed for the previous, but we can try to solve what you have. Good day.

Yemi Bedu

Hi Malla

that error comes when you run that service for the second time.because when u run for the first time specifying all the parameters it runs smoothly and creates a template with the name you have specified in the pipeline of that service.there after if you try to execute the same service it throws storage exception node name already exists because for the second time also it tries to create a template schema with the same name but is already existed

Hello Friends,
I think, need your help to reopen same issue now. I too get the same error message “Node name already exists”. But, I am using wM 6.1 IS and WmEDI only NOT WmEDIforTN as we are running WmEDI for IS without other components. So, I do not have the option to install from webMethods Admin page.

Also, as suggested by SateeshK in the above thread about rerunning the service, I do get this error when I run for first time…

Thanks,
Siva