Not able to connect to IS


I am trying to invoke REST services hosted on IS. I am using ‘Bookstore’ as sample application.

Application is working perfectly in Phoney but when I install that application on Android emulator and run it. I am not able to connect to IS server. IS is hosted on my local machine. I tried connecting using machine name and with IP address but no luck.

I got error message as per screen shot.

I am using ‘ddms’ as debugger tool in android emulator. I got a message ‘02-26 01:08:26.292: D/SntpClient(66): request time failed: Address family not supported by protocol’

Same error I am getting when I am deploying it on my cell phone.

Any idea about this behaviour?


The android emulator takes ports 5554 & 5555 (seemingly even if they’re in use.

Create another port in IS (e.g. 7777) and access on this port.

If the emulator is running, port 5555 will be inaccessible assuming default emulator settings are used.

Kind regards

Hi Dave,

Thanks a lot for your reply!

I changed the IS port it worked fine on android emulator but when I installed that application on my cell phone which is Android based, I was not able to access IS from my cell phone. I am sure, I am missing some configuration to access IS from my cell phone.

Any help would be really appreciated.



Hi sunny,

If I recall correctly, Willem had a similar problem recently with testing an Android device against a local IS via WiFi, and it turned out to be Windows Firewall blocking the communication to the Android device. Could the problem be similar at your end?



Yup, that was the one - turned off Windows firewall & then I could connect fine.