Accessing wM IS from Android device


A question form someone who is rather green in mobile development.

I downloaded the Bookstore application from the Wiki (Thanks Peter for updating it!). I’m running IS on my laptop (not in a VM) & I’ve managed to run the app successfully through both Phoney and the Android emulator. However, I cannot get it to connect to IS from my Android device. I can ping the device from the laptop and I can ping the laptop from the device, but I cannot seem to connect to IS (regardless of what port I use for the IS connectivity). From the emulator everything is just dandy, but from the device I cannot connect to IS - I’ve tried both DNS name & IP address as well as different ports - it all works on the emulator, but nothing works from the device (my home wi-fi network, no proxy, no restrictions that I am aware of).

I realize I am probably doing something stupid (or even more likely, there is something I have to do which I didn’t do) - can someone please assist?

One more thing - what do I need to do to get access to the Mobile Solutions section in Labcase? (I have access to Labcase, but not to this section)


Willem vd Merwe


Have you tried connecting to the IS console through the web browser on the device to see it this works?

Kind regards


Hi Dave,

I was busy testing that when I got your mail (and that of course is also the time my dear laptop decided it hates my network so I had to reboot).

Anyways - problem solved (I’m blushing, trust me) - 2 words (please don’t pack up laughing) - Windows Firewall…

And I always ask people whether they’ve checked the obvious…

So I can say - the bookstore app (for Mobile Designed as opposed to Bedrock) on the wiki is tested on my Galaxy tab & works.