NaturalOne 9.1.1 problem export DDM report

Hi all , please help.

I have NaturalOne 9.1.1 licensed versión.

When i try to save report of DDM as *.csv , it put this simbol ‘/’ as delimiter instead of ‘;’ or ‘,’ .

Then i try to open xxxx.csv but it open lines like this and put it all togehter in one excel cell.

xxxxx/xxxxxx/xxxxxx/xxxxxx/xxxxxxxxxx/xxxxxxx/ ( all stack together in one cell)

Excel needs this :

xxxxxx;xxxxxx;xxxxxx;xxxxxx;xxxxxxx;xxxxxx (with this excel can split data automatically when open) .

¿where i can set up diferent NaturalOne delimiter when i save data?

Need change this delimiter ‘/’ for this one or other compatible ‘;’

Thx , sorry for my english .

Ezequiel - what are you doing that creates a report of the DDM? do you mean “Browse DDM” database browser report? If not, could you explain what you used to “create report of DDM”?

It is also possible to import data into Excel and specify the delimiter. This is a topic for a Microsoft Excel forum, but this screenshot should get you started:

  1. Start a new, blank worksheet, select “Data” menu item

  2. Click on “From Text/CSV”. Browse for your CSV file

  3. From the dialog, under Delimiter select --Custom-- and supply the delimiter ("/") in the box below.

You should be able to load your CSV data with proper column separation. For more questions on how to handle CSV in Excel, please contact an Excel forum.

Good Mornig, thx for your quick response.

I already know how to to that in EXCEL (in my job we have 2010 licensed version ).

Sorry, i cant put here screenshoot of my virtual enviroment job for security, but i have a better example .

Learning Portal :
DASHBOARD >My Courses > NaturalOne Basic (E310A-75E) >start your learning >5.DDM AND Data Browser (Video Demo : Data browser)

Minute 1:41 save report
save selection >>>> Yachts.csv

Here is my problem , when i do that , on my Natural One 9.1.1 at my job , my (fileexample.csv) have inside ( field1/field2/field3) all together .

If i try to open the file in NaturalOne (minute 2:04 of demo video)

But in my Natural One i see thing like this :

field1/field2/field3 (register 1)
field1/field2/field3 (register 2)
… … … …
fieldn/fieldn/fieldn (register n)

Not this 1 . field 1 , field 2, field 3 .

Natural One 9.1.1 do no accept the delimiter ‘/’ the program see a big string not 3 fields.

I already know i can open it in excel doint a lot of clicks and waste time because i need to open EXCEL , check import … utf-8…

I want to do the same way on this demo video , because i need some values to filter DDM browser.

Thx again , sorry for my bad english , i speak spanish,

Thx for help.

Natural One version 9.1.1 (fix #14 applied) job licensed version.
Natural Engineer 8.3.2

I can’t find any setting that influences the CSV delimiter for Browse Data reports so I’d suggest that you open an Empower support request.

This is an example of why I dislike Eclipse. There are so many places to search for any one particular setting that sometimes it seems impossible to find what you are looking for.

Using NaturalONE
→ Using Data Browser
→ Saving a Report
The result is a text file containing, by default, a comma-separated list of fields. The character that is used to separate the field values is determined by the Natural input delimiter character ( ID parameter) as defined in the character assignments of the current project properties.

So, from the project’s context menu, click Properties → Natural → Regional Settings → Input delimiter character. Set the ID parameter to a comma. Click Apply and Close. Re-run the report. Save the report.

OK , thx for try to help, I will change setting tomorrow at job an try again , i will be back here to post a feedback.

Sorry for my mistakes with english.

Good morning.

Thank you , Thank you , Thank you, Thank you, Thank you , i spent a lot of hours trying to solve the problem.

Its working with delimiter ( ; ) it was ( / ) , i had compatibilty problem with ( , ) .

I am the only one on my team working with NaturalOne , all of them work in the mainframe directly, when i learn how to use Natural One i will teach all of them .

I am natural-adabas junior , i dont know if i can get a empower account , we work for very big company , natural-adabas is installed on mainframe ( sorry but i cant say the name of the company ,for security ) .

Again sorry for my mistakes in english , my english writing skill its low , i am from Spain.

Thank you again.

(feel free to close this topic , its solved)