LETTER Ñ In Natural ONE

Naural One Version 9.1.2

customer license

In the Mainframe there are declarations of variables within the programs in this way, for example: #var1 (a20), #var2(n7.2) etc. but when editing a program in NaturaONe the variables of said program appear in this way, Ñvar1 (a20), Ñvar(n7.2), how can I solve that problem. ???

but there is no error message

Atte:

FERNANDO ZARAZUA VILCHIS

1 Like

Make sure the codepage (parameter CP) of your green screen (CICS, COM-PLETE, …) Natural matches the one specified for the NDV server or your server mapping within Natural ONE.

1 Like

I find the CP parameter within the Globals of Natural?

If you are seeing # in the Natural session, then the CP parameter there must be good.

What is the CP setting of your Natural server? In ONE’s Natural Server view, click Properties on the server’s context menu. The default code page is on the General tab.

1 Like

I will try with these instructions and I am going to do some tests where the Variables declared within the programs that are in the Mainframe have an initial # but when the same program is opened in NatualOne that initial is shown with the letter Ñ, I inform you of the result of the test .

Thanks.

  1. Execute the file PCCAdmin.exe in directory ..\Program Files\Software AG\Natural\<version-number>\Terminal\Config to start the Configuration Manager. If user information is required, a logon dialog box appears.
    
  2. In the logon dialog, enter your user name and, if required, password. The default user name is "SYSTEM" with no password.
    
  3. From the File menu choose Open Share File.
    
  4. In the resulting dialog box, select the file NATSHARE411.sag and choose the Open button. This file is located in ..\Program Files\Software AG\Natural\<version-number>\Etc.
    
  5. In the left pane of the Configuration Manager, expand the node Tables and then select the node Translation.
    
  6. From the Edit menu, choose Import Table.
    
  7. In the resulting dialog box, select the translation table files that you want to import and choose the Import button.
    
  8. Confirm that the translation tables for the user-defined files are to be overwritten.
    

From the Natural Studio Menu bar select Tools ? Options. On the Workspace bar, for the 3270 translation in the Terminal emulation section, select User1. Run the program again and the output should now be correct:

These instructions appear to be quite dated and refer to terminal emulation under Natural Studio, but I am still interested in “the result of the test”.

I found PCCAdmin.exe in C:\Program Files (x86)\Common Files\Software AG\Natural\V3\Terminal\configmgr.

I found NATSHARE411.sag in C:\Program Files (x86)\Common Files\Software AG\Natural\V3\etc.

1 Like