E_0623: Variable/field/view must be defined in DEFINE DATA.

using NaturalOne 8.3.8, I have a problem with variables starting with £.
I have the error:
“E_0623: Variable / field / view must be defined in DEFINE DATA.”
What setting can avoid this problem?

It has always been a standard to prefix local variables with a pound sign, which in my experience has been #, also known as a hash mark. I have seen the English pound sign £ used instead, but did not ask how that was done because I had no use of the feature. I am guessing that a code page is involved, but it could be a special zap or macro setting.

Currently we have limited access to product documentation and no access to Empower to search the knowledge base, so I suggest you ask your Natural administrator how this £ support was accomplished on the mainframe. Then perhaps someone on this list can find the corresponding ONE setting.

first of all thanks for this answer.
Then, the use of the £ instead of the # is an internal development standard for the company.
In my previous company this standard was the same and there was no problem because of the £.
I just know that there was a setting of NaturalOne which had been made to prevent the problem
but I have no way of knowing which one.

I assume you’re using ONE against a company NDV-server right ?
This problem usually occurs if you create the project before you drag sources into it.
What you should do is select the sources/library, right-click and chose “create new project”.
The the setting from the NDV-server will be used in the project including the pound-sign.

Otherwise you will have to modify the “.natural” file in the project that contains this info - NOT RECOMMENDED !

In fact, i don’t know if we’re using ONE against a company NDV-server !
All that i know is that i’m selectinng the sources/library on the “Natural Server” Map, right-click and chose “create new project”.
I just came to modify the “.natural” file in the project and replace all the "#’ by “£”
and i don’t have the problem anymore !
So, how can i do to generate a correct .natural file without changing him ?

I very much sounds like it !
-at some point you must have mapped the Natural Server to some machine, which I guess isn’t your local machine :wink:

In my experience using “Create new project” should work because all settings should be taken from the server.
-including Natural Security settings (which is the primary reason I wouldn’t manually edit the .natural!)

Yes, suddenly, it is these “Natural Security settings” that must be changed, but I don’t know how?

Hehe - no “Security settings” are not involved here ! - I just mentioned it as a reason for not changing the .natural manually.

My suggestion would be to contact the one responsible for the central Natural parts (the NDV-server)
It might potentially be an old or non-patched version of the NDV-server that doesn’t fully support NaturalOne.


You can see the NonDbFieldChar parameter in the .natural file, but where is it in the NaturalONE settings? This is what I find so frustrating about ONE (i.e. the Natural plug-in for Eclipse). It can be so difficult to find a particular setting because they are spread all over the place and the search function is rarely helpful. Some settings are under Natural, others are under Java.

In Natural for Windows you can find everything either in the Natural configuration utility or in Studio’s Tools menu under Options. So much easier!