Natural Web I/O Output Linesize > 80

Hi Folks,
in the NaturalONE output window “Natural Web I/O Output” output lines are being truncated
to 80 chars although I have

"FORMAT LS=132"

in my Natural Program.
How can I increase the PageSize & LineSize in the Output Window?
All the best,
DaveLaw

Hi David,

I ran into the same problem myself a while back, but didn’t research further. Maybe this is a good time to look into it, or hopefully someone with a working solution will chime in.

According to the mainframe documentation for Web I/O, on the mainframe it might be as easy as setting TMODEL to a model 5 type for 25 X 132. Not sure how to get a report size 66 x 132.

http://techcommunity.softwareag.com/ecosystem/documentation/natural/nat911mf/webio/webio-intro.htm#webio-intro

For non-mainframe Web I/O, apparently there is a client configuration tool that allows a session to be set up and specifying various parameters including number of rows and number of columns. Not sure if this works with NaturalONE.

http://techcommunity.softwareag.com/ecosystem/documentation/natural/nat911mf/webio/clientcfg-tool.htm#clientcfg-tool

If I get this working in NaturalONE CE, I’ll let you know.

Regards,
George

I found one solution. According to this NDV manual page, before starting NaturalONE you can set these two Windows Environment variables to your desired page size: NWO_NCOLUMNS and NWO_NROWS

http://techcommunity.softwareag.com/ecosystem/documentation/natural/spod1015/ndv/win/ndv/ndv-operateux.htm

I used the Environment Variables dialog box, Control Panel -> System -> Advanced System Settings -> Environment Variables.
I added NWO_NCOLUMNS 132 and NWO_NROWS 60, than started NatONE and ran a report that displayed on a web page 132 x 60. The font is a bit small, but there may be a .css style sheet that controls that.

Thanks for your question that motivated me to go looking for this solution!

Cheers,
George

Hi George,
thanks for your Tips.
So far setting the Vars has had no effect for me.
They are definitely set, which I confirmed in a DOS-Box.
Tried restarting NatONE, even restarted Windows: so far no luck.
But many thanks for your Input, at least its given me a Foothold, a starting-point.
Just need to hack at it a bit more…
…and maybe someone from SAG is reading & can help.
Would be nice!
All the best,
DaveLaw

Just realised I’ve posted on a (slightly) incorrect Forum as we are running the Full Edition, not CE.
So here’s a cross-reference to the posting in the Full-Edition Forum:
http://tech.forums.softwareag.com/techjforum/posts/list/69861.page

ok, the solution is:
the environment-variables NWO_NCOLUMNS & NWO_NROWS need to be set Server-Side, not in the Client where NaturalONE is running.
That’s not well thought out, to put it mildly!
Every User needs their own Server instance to cater for their needs.
Back to the drawing-board…

ok, just to clarify…

If you are working with the NaturalONE CE version, setting the environment-variables NWO_NCOLUMNS & NWO_NROWS on your local PC that NaturalONE CE is executing on works fine. This is because everything, including the Natural Web I/O server is running locally on the PC.

However, once you start working with the Full edition, normally you will be connecting to a server, either mainframe or LUW, and Natural Web I/O will be running on the server. As you correctly point out, the line size and page size would have to be set on the server Web I/O instance, with no easy way for a programmer to specify that when connecting.

I’m glad you were able to find an admin who would set up a separate Web I/O instance for your report parameters. That must be what the LUW configuration utility I read about is for.

Congratulations! Happy computing.
George