Natural output window "More"

Hello,

I installed ADABAS and Natural Community Edition on my Windows 7 64-bit. It installed ok and working good. But I cannot see more than one page in output window when I run a program. I do not see the “more” at the bottom of the window. How do I set it to display more than one page?

Thanks.

Natural on the PC, like Natural on the mainframe, is “page oriented”.

There are two terms you need to understand, “physical page” and “logical page”

Physical page on the mainframe is dictated by the size of your monitor and settings for your system.

Logical page (mainframe) is dictated by settings for the parameter PS (page size).

If you have PS greater than your mainframe monitor setting; two possibilities exist.

If you are going to write a page that is greater than the monitor setting, you will see the first screen, and it will have the characters VVVV at the bottom of the page. This means there is more output below for the page you are looking at. When you reach the end of the logical page, you will see MORE.

On your PC, this situation is handled differently. You will see a scroll bar to the right of your output. Thus you can scroll up and down a logical page.

On the PC, therefore, there really is no need to distinguish VVVV and MORE. Therefore, nothing is shown. To go to the next logical page, you merely hit enter.

Thanks a ton!!!
By just hitting enter, I get the next page.
Thanks again.

In case you want to be able to “scroll” from one logical page to another, try the following:

I have a copycode called AASETC which consists of:

AT END OF PAGE
SET CONTROL ‘C’
END-ENDPAGE
*

I INCLUDE this copycode inside most programs. You could also simply hardcode this in a program.

Now suppose I run the program which produces three pages of output.

All three pages of output, in addition to showing up on the screen, will also show up in the editor area. This now allows me to “scroll” through my output. So, I sort of have the ability to “see” multiple pages as one page.

Some notes:

If you really miss MORE, insert WRITE ‘MORE’ after AT END OF PAGE.

In order for the SET CONTROL ‘C’ to have effect, you must have saved the code. If you simply go into the editor and write a program with SET CONTROL ‘C’ in an AT END OF PAGE clause, and then RUN the program without first SAVE’ing it, you will not see the output in the editor.

To enable the MORE prompt, click

Tools
–> Options…
–> Output Window
–> Display more prompt

As for as the SET CONTROL ‘C’ statement, it is not necessary to save the module first. (I save only what I intend to keep.) The alternative is to enter the command E on the command line (command window) after execution completes.