Natural/ADABAS simulator for windows

Hi ,
Recently while opening a DDM in windows application, I am receiving an error of " editor columns cannot be generated" .
The natural error is NAT3048.
Details have been attached.

DDM.docx (495 KB)

What is this “simulator” you keep referring to? When asking for assistance, please be specific as to what product and component (and version) you are using.

A NAT3048 is frequently an issue of having multiple sessions open with the same identification to Adabas. Try starting your Natural (Natural for Windows in your case) with the Natural parameter setting ETID=" ". This will cause each session to generate a random transaction identifier and avoid NAT3048 conflicts. If you are using Natural Security, you may need to adjust the profile settings for the user/library.

Hi ,
Thanks for the response.
The simulator I meant was “Natural for windows community edition 8.3 Version”.

My issue is while opening a DDM , it gives a response as “editor columns cannot be generated”.(I have attached herewith all the screenshots.)

The ETID is spaces only and let me if I need to check anything more with security what you have informed.(Attaching screen shot will be helpful)

Natural Security is not included in the community edition, so that is not an issue.

Set the ETID parameter to $$. (The blank value is typically a mainframe setting.)

What is your UDB setting? Is the UDB database active?

What command do you issue prior to seeing the “editor columns cannot be generated” message?

I have tried by setting the ETID=$$ and that is also not working as expected.

Regarding the UDB setting ,please let me know how and where can I check the same.(Also if anything specific to check that the database is active or not).

I am just double clicking the DDM and getting the response as “editor columns cannot be generated”

Screen shot attached ,once I click OK, the windows session is getting closed.


Presumably you changed the ETID parameter using the Configuration Utility. The UDB parameter can be set there, too.

Rather than opening the DDM in the FNAT, try copying it (VEHICLES) to a local library. The simplest way is with drag-and-drop.