MWS 8.2 install fails with "java.lang.OutOfMemoryError" "Java Heap Space"

I am trying to install MWS 8.2 on a windows 2003 server with 4 GB RAM.
The step to Run the default MWS instance always fails with the “java.lang.OutOfMemoryError” “Java Heap Space” .
I have tried: shutting down all other non-OS applications, increasing virtual memory, changing the boot.ini to /3Gb.
But, still hit the “java.lang.OutOfMemoryError” “Java Heap Space”.
The server.properties.bat has JVM_OPTS=-Xms32m -Xmx1024m … etc.
The “java.lang.OutOfMemoryError” “Java Heap Space” always happens after the java.exe hits above 1 GB.
What else can I do?

I see you have enough memory!

Can you delete the default mws instance and create a new one? I hope you know how to do this :slight_smile:

Yes, I run vendor scripts to delete old default , create new, and then try first time run:

step3.bat (cd /d %WMDIR%\mws\bin
mws -s default delete)

step3a.bat ( cd /d %WMDIR%\mws\bin
mws new -Dhttp.port=%MWSHTTPPORT% -Ddb.type=sybase -Ddb.url=jdbc:wm:sybase://%DBSERVER%:%PORT%;databaseName=%DBNAME%;SelectMethod=cursor -Ddb.username=%MWSUSR% -Ddb.password=%MWSPWD% -Ddb.driver=com.wm.dd.jdbc.sybase.SybaseDriver)

above 2 steps step3.bat and step3a.bat work, but step3b.bat below fails with java.lang.outofmemory error
step3b.bat (cd /d %WMDIR%\mws\bin
mws -s default run)

Can you attach these full.log and problems.log

attached full and problems
full.log|attachment (88.9 KB)
problems.log|attachment (3.61 KB)

Try to uninstall and re-install the MWS alone. If it did not resolve the issue, try the below;

Settings in server.properties.sh

JVM_OPTS="-Xms32m -Xmx2048m -XX:MaxPermSize=128m"

OR

JVM_OPTS="-Xms32m -Xmx2048m -XX:MaxPermSize=512m"

I am on a windows 2003 server with 4 GB RAM
When I tried to use server.properties.bat -Xmx1280, the JVM throws an error and
won’t start.
“Error occurred during initialization of VM
Could not reserve enough space for object heap
Could not create the Java virtual machine.”

Even with boot.ini /3Gb and increased virtual memory, I can’t get -Xmx above 1024m.

I also ensured that HIPS is turned off.

Second part: If I run webmethods installer, can I uninstall and then reinstall just the MWS portion? Will it remove windows services and registry entries?

Before you uninstall the MWS can you run the db configuration to check whether the MWS component (tables are created) are installed successfully.

Is this your DEV or PROD environment?

It is dev so i can re-install.

I used these steps in previous step:
echo “Creating the MWS components…”
call %WMDIR%\common\db\bin\dbConfigurator -a create -d sybase -c MWS -v latest -l jdbc:wm:sybase://%DBSERVER%:%PORT%;databaseName=%DBNAME% -u %MWSUSR% -p %MWSPWD%

echo “Creating the TNS components…”
call %WMDIR%\common\db\bin\dbConfigurator -a create -d sybase -c TNS -v latest -l jdbc:wm:sybase://%DBSERVER%:%PORT%;databaseName=%DBNAME% -u %MWSUSR% -p %MWSPWD%

echo “Creating the TNA components…”
%WMDIR%\common\db\bin\dbConfigurator -a create -d sybase -c TNA -v latest -l jdbc:wm:sybase://%DBSERVER%:%PORT%;databaseName=%DBNAME% -u %MWSUSR% -p %MWSPWD%