Missing Package contents in IS after creating in local service

[youtube]https://www.youtube.com/watch?v=YK5o9rQbgpU&feature=youtu.be&t=2306[/youtube]

Hello guys,

I encountered a problem after clicking the Local Service Development Project in the Package, The contents of the package is missing in the Software AG Designer (refreshed it a lot of times) but the folders/files are still intact inside the local IS.

How to retain the contents of the package in the Designer?

Thank you.

Hi,

try to reload the package and check the server.log for messages occuring.

Did you try to start over the Designer workspace?

Regards,
Holger

Hello Holger,

What do you mean in reloading the package, Is it refreshing the package in the IS?

I’ll also try to check the server.log but where can I find the server.log is it under the profiles from C:\SoftwareAG\profiles\IS_default\logs or C:\SoftwareAG\IntegrationServer\instances\log and
what specific messages occurring in the server.log that I need to check ?

I tried to restart the Designer workspace but the package still doesn’t have any contents.

Hi,

hopefully you will find the server.log here: C:\SoftwareAG\IntegrationServer\instances\default\logs

There should be something like “package cannot be loaded due to dependencies” or “unable to load node for service” with a more detailed explanation why it is not able to load.

Additionally check for the manifest.v3 file in the root of the package as it contains informations needed while loading the package.

Check the files (mainly flow.xml, node.ndf, node.idf) in the package (under /ns-folder) with an editor if their xml structure is still valid. Sometimes it can happen that these files get corrupted during save.

Regards,
Holger

Thank you, I can already see the server.log

After trying to create a local service development, the package reloads and denotes an Error: [ISS.0081.9001] Node does not exist

And also the package I have created doesn’t have (mainly flow.xml, node.ndf, node.idf) in the package (under /ns-folder).

Thank you.
Capture.PNG

HI,

when using Local Service Development, any new nodes will be created locally.

When there is an IS out of LocalServiceDevelopment is involved the package and its contents needs to be Uploaded to this instance first.

Regards,
Holger

Hi,

I am also facing same problem, I dont see any actual solution for this.

  1. I created one service “MyTest.testservice” in Designer 10.1
  2. Executed/run the service successfully.
  3. I did right click on package name MyTest > ‘Create Local service Development Projet’ > provided all necessary details like Repository, Working tree, path within repository.
  4. When I click on Finish I get the error pop-up (as per details below).
  5. If I click on the Package “MyTest” to explore the services, I don’t see anything inside the package.

Could not load
testservice.

Reason
[ISS.0081.9001] Node testservice does not exist

Please share the solution if available.

Regards,
Hukam

In my case, below solution worked.

Root Cause:

After checking in the Designer workspace log file (C:\Users\hukam\workspace101.metadata.log), I found below message:

!ENTRY com.softwareag.is.vcsintegration.showfiles 4 0 2018-03-16 14:32:13.093
!MESSAGE C:\SoftwareAG101\IntegrationServer\instances\default\packages\MyTestSuiteDemo: A required privilege is not held by the client.

!STACK 0
java.nio.file.FileSystemException: C:\SoftwareAG101\IntegrationServer\instances\default\packages\MyTestSuiteDemo: A required privilege is not held by the client.

           at sun.nio.fs.WindowsException.translateToIOException(WindowsException.java:86)
           at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:97)
           at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:102)
           at sun.nio.fs.WindowsFileSystemProvider.createSymbolicLink(WindowsFileSystemProvider.java:585)
           at java.nio.file.Files.createSymbolicLink(Files.java:1043)
           at com.softwareag.is.vcsintegration.showfiles.actions.MoveProjectToPackageAction$3.run(MoveProjectToPackageAction.java:417)
           at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

=============================================================================

it clearly states the reason i.e. “A required privilege is not held by the client”.

Resolution:

I started the Designer as Administrator (i.e. right click on Designer icon and then choose option ‘Run as Administrator’), it started working for me :).

Install latest Service Development fixes of Designer. This looks more like Designer problem.

You can browse through IS Admin page, Management > Packages > click on the package > browse services. If you can find the service here, its no problem and only your designer has problem.

Even, I faced the above issue and it resolved after running the designer as Administrator.

But the problem is I dont have the administrator access and asked our infra team to run the eclipse as administrator.

So, wanted to know if there is a permanent solution for the problem.

Thanks.

I am on 10.5 and I found another way this can happen - I’m running with an internet that cuts in and out at times and during startup the internet cut out and lost contact with the domain controller, So it didn’t think I had permissions to run this and thus the issue.

Restarting designer fixed the issue.