Macros functionality in Web Enablement - Instant Web Application with ApplinX 9.5

We have a web application that is generated using Web Enablement - Instant Web Application methodology.
We need to implement Macros functionality so users can record their steps.
We know that Macros functionality is working when we use pure HTML Emulation approach. However for Instant Web Application it only partially works.
Here’s the code that was added to template.master:

Macros

It opens up Macro dialog, but it doesn’t seem to record any of the steps.
Are we missing something?

Hi Yelena,

Please try to add this line to the code:

<jsp:include page="/z_emulationDialogs/z_macroPanel.jsp" flush="true"/>

It should solve the problem.

Let me know if you need anything else.

Regards,
Gadi

Hi Gadi,

Thanks for your reply. We are using .NET enablement and therefore do not have the include page you refer to.
We do have however z_macroPanel.ascx, z_macroPanel.ascx, z_macroView.aspx, z_MacroView.htm

The problem we have is that Mocro popup window does appear and we can save user Macro, however none of the steps gets recorded. I am attaching the .gxm file here where you can see that all the steps are null.
I wonder what’s the reason for that. The HTML emulator version is working but we need it to work for Instant Web Enablement.
__1.zip (439 Bytes)

Hi Yelena,

These are the steps I did in the .NET web application to get the Macro functionality working:

  1. Add the Macro configuration to gx_appConfig:

<MacroConfig>
	<EncryptData>true</EncryptData>
	<Flicker>0</Flicker>
	<UserName>$(IP)</UserName>
	<MacrosFolder>z_emulationDialogs/userMacros</MacrosFolder>
</MacroConfig>
  1. Add this line to template.master:

<%@ Register TagPrefix="macro" TagName="Panel" Src="./z_emulationDialogs/z_macroPanel.ascx" %>
  1. Added this line to the template.master, to add a Macro option to the menu links (another after the “other…” option):

<tr>
<td class="menulink" align=center valign=top>
<a style="color:#114773; text-decoration:none;;" href="#" onClick="z_openMacroDialog();" onMouseOver="window.status='Macro...';return true;" onMouseOut="window.status='';return true;">
Macro</a><macro:Panel ID="macroPanel2" runat="server" />
</td>
</tr>

*of course you can use whatever you want to trigger the macro dialog

  1. Added this to the z_macroDialog.htm file in the section:

<script src="z_resourceReader.aspx?res=z_emulationDialogs/z_macros.js"></script>

Let me know if this helps.

Regards,
Gadi

Hi Gadi,

I’ve completed the solution before you posted your reply. Thank you - nevertheless.
I did steps similar to what you’ve described. Here’s what worked for me:

  1. template.master header:
    <%@ Register TagPrefix=“macro” TagName=“Panel” Src="~/z_emulationDialogs/z_macroPanel2.ascx" %>
  2. template.master markup
													</td>
												</tr>	
  1. z_emulationDialogs/z_macroPanel2.ascx
    <%@ Control Inherits=“com.sabratec.dotnet.framework.web.macros.GXDotnetMacroPanel2” %>

Macros
4. config/gx_appConfig.xml

false
0
z_emulationDialogs/userMacros
true
$(IP)

Thanks again for your suggestions.