Local service development - "Load IS Package" option is not visible in navigator

I am trying out the local service development feature with webmethods. I am using SVN as my repository.

First I have uploaded few my existing application packages directly on the SVN repository, now to use local service development. feature. i need to check out these packages and load them on my local integration server.

When i do check out the package from SVN repository, the package is visible in navigator view with > sign on it (as mentioned in documentation) and also its visible in my workspace as well.

As per webMethods documentation, i should be able to load this package on local IS by right clicking on the package in navigator view and selecting the option “Load IS Package”

However i dont this option “Load IS Package” or “Move Project to IS Package” in navigator view at all.
Can someone help on this if they encountered this issue before?

You need to check-in the packages using designer , checking in the package by using “Create Local Service Development Project” , creates a .project file which is required to get the context menu of “Load IS Package” when you check-out a package.

1 Like

Hi Rakesh, Thanks for your reply.

I get the option “Move Project to IS Package” for the packages which i have checked in previously to SVN from designer.
How about the packages which i have not checked in before? Do i need to follow the following steps-

  1. Extract the package from SVN / Source repository (could be IS)
  2. Load it local IS and designer.
  3. Choose “Create Local Service Development Project” for this package and share it with SVN.

My question is regarding the process that needs to be followed…
We have so many application packages, so in order to use this feature does every developer needs follow the above steps for each and every package?

Hi Bhaskar ,

If the packages are not present in svn then you can follow the above steps for check-in of packages to svn.

Point to be noted is :

  1. Full package check-in is one time task .
  2. After that each developer need to checkout the packages on their local server and commit their changes.

Hi Bhaskar.

Try going into project Explorer view and “Add Project Nature”

After this you will see the “Move Project to IS Package” in the context menu…

This is required when you check out stuff from version control which was not originially created in your workspace.

Thanks Varghese and rajesh for the reply.

Varghese, I am not able to see the option “Add Project Nature” in project explorer view? Can you please help me with the detailed steps for this?
Also I am using designer version 9.7 … so I am not sure if that option is available?