jdbc Adapter in Windows Authentification

Hello,
Im wondering how I can create a Adapter in Windows Authentification.
Is it the windows service of IS wich open the connection ?
And How I have to set this connection ?

Is it possible to put another AD user as user of connection ?
Is it possible to put a windows account (without password ) ?

For information wM 9.10.

Thanks

Hi Vital,

which JDBC Adapter version are you using (9.0 or 9.10)?
Any Fixes applied?

Did you check the JDBC Adapter Users Guide?

Regards,
Holger

It is 9.10.

Where I can find it ?

Hi,

you can find the Guide in Empower under “Products & Documentation” or here in the Forum under “Forum → Documentation”.

Regards,
Holger

I have problem to access to documentation : I have a http 443 forbidden error

Hi Vital,

you will have to ask community administration team to allow you access to the documentation.

If you have Empower Extranet & KB access, you should be able to access documentation from there.

Regards,
Holger

Hi,

If your IS is running on a Windows Server it shouldn’t be too difficult.

You can google for “MSSQL JDBC windows authentication”.

It basically boils down to add “integratedSecurity=true” in the options and having sqljdbc_auth.dll from the latest Microsoft JDBC driver in place.

Best regards,

Ok I tried to follow the statement in :
http://techcommunity.softwareag.com/ecosystem/documentation/webmethods/adapters_estandards/Adapters/JDBC/JDBC_9-10/9-10_Adapter_for_JDBC_Install_and_Users_Guide.pdf

I download the sqljdbc_auth.dll file from web and I copied in SAG Directory \ Common \ Security \ ssx_64 \ bin folder as Specified in p 90.
After that, I change the user of Intergration Server service and I put a Windows account which have right on database.

I restart the Intergration Server and in adapters, I change the otherProperties. I set : integratedSecurity=true; authenticationScheme=NativeAuthentication

I put no user name neither password in the connection.
I try it and it dosen’t work

Error?

No error,
It take times when I click Enabled button and it stays on No without blue error in header of Adapters page.
When I refresh (F5) I have pending Enables as Enabled Status and when I wait, I have No as Enables Status

Then you have to set the logging levels to TRACE on IS logging under settings for WmJDBC Adapter.

Also check if there are any messages on Server/Error logs.

How can I change the login level ?

OK I have a message :
This driver is not configured for a integrated security. (Actually the message is in French but I think it is the good translation).

Did you do this?

  • Set the authentication file to be in the environment PATH for system.
  • Copy sqljdbc_auth.dll to location : SAG root directoty\ IntegrationServer\instances\default\lib
  • Copy sqljdbc4.jar to location: SAG root directory\ IntegrationServer\lib\jars.

Restart IS.

It’s work,
I have done Nothing else but what I have done before.
The only thing is I haven’t the good version of sqljdbc_auth. I download from the Technet Site.

Hi,

the jar should be placed under IntegrationServer\instances\default\lib\jars\custom instead of IntegrationServer\lib\jars.

But I would prefer to place the jar under IntegrationServer\instances\default\packages\WmJDBCAdapter\code\jars\static.
Subfolder static in this case to get the jar loaded during IS start and not during package start as it refers to the dll library.

Additionally you should consider switching to sqljdbc42.jar or better mssql-jdbc-6.2.2.jre7.jar.
When using Java 8 there is also a mssql-jdbc-6.2.2.jre8.jar available.

Regards,
Holger

Hi,
I hadn’t done nothing concerning sqljdbc42.jar.
I have just changed the sqljdbc_auth file in SAG Folder\common\security… folder as it is explained in JDBC Adapter User Guide in documentation

HI,

You must have the jdbc driver and authentication library from the same version.

Follow: https://docs.microsoft.com/en-us/sql/connect/jdbc/microsoft-jdbc-driver-for-sql-server

Good luck.

Hi,

which driver version to use depends on the version of MS SQL Server being used.

Newer Server versions might not be supported by older drivers.

Regards,
Holger