Following tutorials; can't import package

I have a zip file that is a package that I downloaded for the JDBC tutorial. I have put the zip file in C:\softwareAG912\IntegrationServer\replicate. When I’m in Integration Server and choose Packages, Management, Install InboundReleases, no files are listed. It says “No inbound releases”. I have looked and looked for what I may be missing and I don’t see what it could be. I even downloaded the zip file again in case it was a bad file. It doesn’t see the second copy in the same location, either.

You need to put it under C:\softwareAG912\IntegrationServer\instances\default\replicate (if you are using the default instance).

Thanks and Regards
-Sanjan

Correct path is C:\softwareAG912\IntegrationServer\instances\default\replicate\inbound\

1 Like

If you have multiple instances of IS in same installation you also need to locate instance directory as well.

C:\softwareAG912\IntegrationServer\instances<instancename>\replicate\inbound\

Replace with the instance name. if you have only one instance “default” then C:\softwareAG912\IntegrationServer\instances<instancename>\replicate\inbound\ should work

Thanks,
Manoj

1 Like

Thank you. It worked to put the zip fle in C:\softwareAG912\IntegrationServer\instances\default\replicate\inbound.

Now, when trying to connect, it can’t file “com.microsoft.sqlserver.jdbc.SQLServerDatasource”.

Neither can I. Where is that supposed to be? Was I supposed to get that from somewhere?

If it makes a difference, I’m working with SQL Server Express on my localhost.

Many thanks in advance!

This is it as Mahesh pointed out:

Correct path is C:\softwareAG912\IntegrationServer\instances\default\replicate\inbound\

HTH,
RMG

1 Like

You need to Place sqljdbc jar under IntegrationSever/instances//packages/WmJDBCAdapter/code/jars/ and reload the package WmJDBCAdapter in the IS Admin UI before trying to configue any connection.

Thanks,
Manoj

1 Like

Hi Amy,

If the still above solution doesn’t work then try to place the jar file in the static folder location as below:

sqljdbc jar under - SAG_912Home_IntegrationSever/instances//packages/WmJDBCAdapter/code/static/jars/

HTH,
RMG

I don’t have a folder there called “static”. Should I?

rmg -

That seems worse. Now I get:
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource JDBC_Tutorial:MyConnection.
[ART.118.5063] Adapter Runtime (Connection): Unable to start connection JDBC_Tutorial:MyConnection: after 1 attempt(s).
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.204] Cannot connect to the database with DataSource class “com.microsoft.sqlserver.jdbc.SQLServerDataSource”.
The TCP/IP connection to the host lihbg228n6p0011, port 1433 has failed. Error: “Connection refused: connect. Verify the connection properties, check that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port, and that no firewall is blocking TCP connections to the port.”.

Before this, I was getting:
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource JDBC_Tutorial:MyConnection.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
com/wm/adapter/wmjdbc/connection/ConnectionInfo

Hi Amy,

remember to reconfigure the JDBC-Connection from MySQL to MS SQL after applying the driver jar.

@RMG:
This will only be neccessary when the driver has native portion, but the MS SQL driver is plain java.
The correct path in this case will then be SAG_912Home_IntegrationSever/instances//packages/WmJDBCAdapter/code/jars/static.
Just the last two folder names switched.

Regards,
Holger

Holger -
Where is that reconfiguring done?
Is MySQL the default somewhere? I’ve never set it up for that.

I did reload the WmJDBCAdapter, and the JCBD_Tutorial.

Thanks for all who helped! I finally got connected.

I got a little help from someone here, too. I finally got all the copies of the jars in the required places. Then the last hurdle was getting it to accept the login to the SQL Express database and now that’s working, too.

Thank you all.