JDBC Adapter: \"...could not establish connection...&am

I am configuring a JDBC adapter on a HP-UX 11.11
And I get the following error message:

3:22:12 PM (904) Start adapter process in test mode.
3:22:16 PM [Adapter] (085) The adapter process could not start up.
3:22:16 PM (314) Could not connect to database “jdbc:oracle:thin:@krakatoa:1521:crpdx” as user “sa”
3:22:16 PM (17002) Io exception: The Network Adapter could not establish the connection
3:22:17 PM java.sql.SQLException: Io exception: The Network Adapter could not establish the connection
3:22:17 PM (195) Process exited with code 1.

Any idea where the problem could be?

Have you had a resolution to this problem? We are getting the same error. We are trying to connect to an Oracle 8i database using the 4.2 JDBC Adapter in Enterprise Server.

1:38:10 PM (314) Could not connect to database “jdbc:oracle:thin:@hcgtww:1521:GTW” as user “system”
1:38:10 PM (17002) Io exception: The Network Adapter could not establish the connection
1:38:10 PM java.sql.SQLException: Io exception: The Network Adapter could not establish the connection
1:38:10 PM (195) Process exited with code 1.


me too, somebody help ?!

First verify that the server where your adapter is installed has network connectivity to your database server.

I usually try to do a ping of the database server, first with the host name (eg. ping krakatoa, or ping hcgtww). If that doesn’t work try pinging the IP address of the db server. If you can ping by IP address and not host name, then your adapter server doesn’t understand your database server host name. If this is the case you can either:

  1. Make sure your DNS server is defined properly on your adapter server so that the host name lookup can be resolved OR define an alias for your host name on your adapter server (eg. in Windows O/S host names are defined in the host file in C:\WINDOWS\system32\drivers\etc. I think on Unix they are defined in the /etc/hosts file )
  2. Use the IP address of your DB server in your database connection. It is a quick way to make sure your DB connection is ok, but it’s not a recommended best practise.

Give it a try and let me know.


Hi all…there might be another problem here…
see if your firewall on the database machine is ON then it might now allow you to connect to the database port…

Also at times the firewall might not even allow you to ping to a computer…
i had this problem before and disabling the firewall did the trick for me…


I have a similar problem with SQLServer database connection. My laptop and desktop have similar configurations (Win/XP/Pro, WM 6.1, SQLServer 2000). Both are on a local network but I am testing jdbc connectivity within localhost (IS and SQLServer on the same machine).

My laptop works fine but my desktop gives the follwing error when I test the pool aliases:
IS Admin—>JDBC Pools–>Functional Alias Definition–>DocumentHistory–>Test
Restart Function DocumentHistory Failed
[Microsoft][SQLServer 2000 Driver for JDBC]Error establishing socket.

I added the following line to server.cnf

The following jar files exist in [IS home]\lib\jars folder

When I test the connection to the wm database via a java service I get the following error:
TestConnection - Error: java.sql.SQLException: [Microsoft][SQLServer 2000 Driver for JDBC]Error establishing socket.java.lang.NullPointerException

Any suggestions?

You cannot use the Microsoft JDBC driver with the built-in pools (eg. DocumentHistory) for webMethods 6.x. You must use the JDBC driver webMethods ships with the product (Datadirect Connect JDBC) to connect to built-in tables (custom tables are another matter, you connect to them with the JDBC Adapter and it can use many different types of driver).

The installation guide lists the correct steps to follow in the section titled “Configure Integration Server”. Specifically look at the section dealing with “Database URL”. The URL to use with 6.1 should be similar to:



Here is additional info. I am diagnosing the problem in three ways,

  1. configure jdbc pools (with DD driver),
  2. create jdbc adapter connection (with MS driver),
  3. run java service to establish connection via
    con = java.sql.DriverManager.getConnection(getConnectionUrl(),userName,password);

All three approaches fail on sys118 and succeed on two other systems (in localhost mode).

Approach 3 connects successfully FROM sys118 TO 2 other systems, but not FROM the other systems TO sys118.

The main difference between sys118 and the other two systems is that Windows Firewall is installed on sys118. Apparently the firewall prevents functioning of incoming sockets. I turned off the firewall but the incoming sockets still fail. I cannot figure out how to de-install the Windows Firewall on sys118.

This appears to be a Windows issue, not webMethods (although other webMethods users may encounter the same problem).

I removed Win SP2 which contained the firewall.

I found my problem. I replaced the DB URL as follows:

bad URL:

good UL: