Configuring JDBC Adapter in WIN XP home

hi,
I am a very new to webMethods, started pickin up things over the past week. I have installed webMethods IS v6.1 on my system having Win XP Home, and i have installed Oracle DB on the same system.
When i try to configure the JDBC Adapter for the Oracle DB, it gives me the following error–

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource ACME.Adapters:TestConnection.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.204] Cannot connect to the database with DataSource class “oracle.jdbc.pool.OracleDataSource”.
Io exception: The Network Adapter could not establish the connection

There is another problem related to it, when ever i try to test the jdbc adapter, the TNS listner fails.

Please let me know where did i go wrong.

Thanks for all your help.
Shantanu

Shantanu,

Please use the search functionality in this site,lot of threads discussed on this same issue.you will see the results.

Also make sure the classes12.zip is copied in the IS/lib/jars directory.
and also execute the necessary oracle scripts in the webMethods61\common\db\scripts\create and restart the IS and try to create Adapter connection.

HTH,
RMG.

RMG,
Thank you for tips.
I made sure that i have copied the classes12.zip in the proper path. And i had run the oracle scripts too.
But every time i try to enable the jdbc adapter, i get an error from the TNS listner and the TNS listner stops working.
Does it have anything to do with my installing the products on XP home edition.
Thanks for all your help.
Shantanu

Shantanu,

Have you tried to make a connection to your database with SQL*PLUS?

Try to connect using another client first. Then, move forward with trying to get the JDBC adapter to run.

In regards to RMG’s post about the db scripts: you only need to run these if you plan to use webMethods to persist your logging functions or for the TN datastore. Otherwise, running the scripts is not necessary. Also, you should use the built-in drivers for these functions, as they are supported.

I run Oracle 10G on my laptop and desktop, both running win xp home with no issues. I have also run 9.x without any issues.

HTH

Ray

Shantanu,

Installing the IS and DB on XP home will work with out any problems.
please make sure as Ray mentioned above.

Regards,

hi RMG/ Ray,
I tried connecting to my database using SQL*PLUS, and it works. Even then the jdbc adapter was not working and the TN was also not working.
So i uninstalled the db and re installed it.
Still the problem persists.
Whenever i try to configure the jdbc adapter, the TNS listner fails.
Please let me know what else i can try to fix it.
Thanks for the help.
Shantanu

Shantanu,

I am sure that it is a configuration problem, bad driver, no driver, etc type of problem. First, make sure that you have the classes12.zip file in your classpath. This can be determined by clicking the about button on the admin home page and located the classes12.zip file.

If you don’t have it, get it from the Oracle site and drop it in the /lib/jars directory (read the manual.) Restart the server, try again.

If this doesn’t work or if you have the JDBC driver already installed as per the prior, then it is in your configuration. Remember, you already tested the connection to determine if the username/password is valid.

In the configuration entries, under OTHER PROPERTIES, make sure that you have this: driverType=thin

Without that entry, it will not work.

HTH

Ray

Ray,

Thanks for taking time to respond my post.

I have done it already and once or twice i succeeded connecting trading networks, too. But because of fluctuating behavior of TNS listner, i cannot connect to TN for long and create some TN objects.

I had make sure about the classpath, too. classes12.zip is in classpath of the IS.

If you can find out something more about this problem, it will be a great help.

Regards,
Shant

Guys,
One more thing I want to add to it is this is not the problem occuring while i try to connect to JDBC adapter. I can start TNS Listner successfully. If i do nothing, it will go on and on. But as soon as i will try to connect to database using SQL Plus or WebMethods JDBC Pools or JDBC Connection, TNS Listener goes off. So I am not sure, where the problem is.

Regards,
Shant

Looks like you have a stability problem on the listener side since you can connect to the db already in webMethods (which you did not mention in any previous posts).

I would examine the database to make sure all of the patches are up to date. Also, examine your OS to make sure all of the patches and security fixes are up to date.

Also, keep in mind, that many of the microsoft patches lock down ports, etc. so this could also be a problem.

If you determine that this is the case, then you can deploy a network analyzer (packet sniffer) to figure out if the data is getting back and forth.

There is another thing you can do as well. You can increase the debug level in integration server in the hope of trying to catch a more meaningful message.

Examine the JDBC documentation and try to determine what settings you need to make to enable JDBC comms debugging. Every adapter supports this.

I know that the data direct adapters definitely support this but it requires some external software from data direct.

HTH

Ray

hi,
I tried configuring the oracle, but it did not work out. So i uninstalled the oracle and installed MSDE SQL 2000.
Then i tried configuring again… with the following string
jdbc:wm:sqlserver://localhost:1433;databaseName=shantanu/wmdb;SelectMethod=cursor.
but i am still getting this error…
[wm-cjdbc33-0009][SQLServer JDBC Driver]Error establishing socket. Connection refused: connect

Please let me know where i went wrong.
Thanks for all the help.
Shantanu

> but i am still getting this error…
> [wm-cjdbc33-0009][SQLServer JDBC Driver]Error establishing
> socket. Connection refused: connect

Has XP Service Pack 2 or another firewall product been installed on this system?

XP SP2’s built-in firewall is turned on by default and may be blocking these connections.

hi Sonam,
Thanks for taking time out for this.
Yes i have XP service pack 2 installed on my system. And i had Mcafee firewall installed earlier but it is disabled now.
Is there a work around to this problem ?
Please let me know.

Regards
Shantanu

Instead of localhost try to use your server name.

Thanks
Krishna

Shantanu: I’m not sure what the next steps are - I don’t have SP2 installed at work.

Take a look at the help for Microsoft firewall. Perhaps you can change some firewall settings to allow inbound connections to port 1433.

Shantanu,

Go to www.sysinternals.com and download a free piece of software called tcpview. TCP View will display a list of ports that various programs use. You will be amazed at the ports that start and stop with the broker, workflow, IS, etc.

It will list the process, PID, and port for the database. Also, check the windows event log, windows security log to see if there is any relevant data.

IF all of the software is on the same box, I am stymied as to why it will not work. I have never heard of a firewall blocking internal calls on the same exact box unless you are using IP addresses in the URL.

If this is the case, then use either localhost (which will not always work in webMethods java land) or use the hostname (like DESKTOP) or whatever the computer name is. This will save you a trip to the router if you have one.

Alternatively, you can try loopback 127.0.0.1.

Ray

Shantanu

I am facing the same problem.

If you were able to fix your problem. can you please post your resolutions

Guys

I came across the same problem
> [wm-cjdbc33-0009][SQLServer JDBC Driver]Error establishing
> socket. Connection refused: connect

I would share my story so someone will benefit someday.

I do not know if it was microsoft firewall or mcafee firewall or SP2 or what, but my working system one fine morning stopped connecting. Ofcourse i tried to connect after disabling the firewalls and had no luck.

The system was IS4.6 and the database alias thing just wont connect in fact it did not give any such meaningful error for me, it just said

“com.wm.app.b2b.server.DBConnectionException: Connection refused: no further information”

I was initially using the TDS driver, so I tried connecting SQL server driver, still no luck. So I wrote a java client to see if I could really connect that is when I got the error

“Error establishing socket. Connection refused: connect”.

I checked the network properties from SQL SERVER Enterprise Manager to make sure that the port was enabled and it WAS.

But when i tried to telnet it I realised that the port was not listening. I disabled the tcpip connection from enterprise manager and enabled it and it started working.

I then went ahead and installed SP3 for sql server and it looks like it had solved the problem.

So my small advice, ensure that the server is listening in the port by telnetting it even though it says else where that it is listening.

Thahir

Applying SQL Server 2000 Service Pack 3 did the trick for me.

Regards