JDBC Adapter Connection For SQL Server 2000

Hello,

I’m trying to configure a JDBC Adapter Connection for SQL Server 2000; I looked into the documentation but I’m still having an Adapter Run Time exception error. My guess is the “DataSource Class” is not correct.

Could someone forward me the correct configuration for SQL Server 2000!

Regards

Did you ever get an answer to this question?? I have the same question!

This worked for me:

  1. Installed the Microsoft SQL Server 2000 Driver for JDBC from http://www.microsoft.com/SQL/downloads/2000/jdbc.asp

2.Added Microsoft SQL Server Driver jars to wM6.
Copy all files (msbase.jar, mssqlserver.jar & msutil.jar) from the \lib to \IntegrationServer\lib\jars.

To use this driver specify the following using Adapters > JDBC Adapter > Configure Connection Type:

DataSource Class com.microsoft.jdbcx.sqlserver.SQLServerDataSource
serverName
user
password ******
databaseName
portNumber 1433

See the 'webMethods JDBC Adapter User’s Guide V 6.0 located in \IntegrationServer\packages\WmJDBCAdapter\docWmJDBCAdapterUserGuide.pdf for more details

Good luck!

I think you omitted a step where each of the above jars must be added to the classpath in the startup script (server.bat).

Even after modifying classpath I get the message “Test of TN failed, No suitable driver” when I run the “Test” function.

I checked “About” to verify that the jars were indeed in the classpath. Inspecting the mssqlserver.jar shows that the following class is within the jar.
com.microsoft.jdbcx.sqlserver.SQLServerDataSource

I suspect my problem is the sql userid/login. I tried using both windows authentication and SQL server authentication.

Also, I don’t see where to specify the database name in the JDBC adapter configuration.

Hi,
Even after doing all the config settings I am getting the following error,
[ADA.1.204] Cannot connect to the database with DataSource class “com.microsoft.jdbcx.sqlserver.SQLServerDataSource”.
[Microsoft][SQLServer 2000 Driver for JDBC]Error establishing socket.
Is there any solution?
Pl let me know
Thanks
Bipin

Hi. We are using Microsoft SQL Server 2000 for our webMethods databases/tables.

When I setup my connection pools I used the driver:
DataDirect Connect JDBC SQL Server Driver
(com.wm.dd.jdbc.sqlserver.SQLServerDriver)

Here’s the pool alias I setup:

Alias Name: Dev_Audit_ConnPool
Associated Driver Alias: DataDirect Connect JDBC SQL Server Driver
Database URL: jdbc:sqlserver://AUG-SQL70\AUGSSQL12:1433;databaseName=wmaudit;SelectMethod=cursor
Minimum Connections 5
Maximum Connections 40
Idle Timeout 60000 milliseconds

I then associated this pool alias with the functions names: ISCoreAudit and ProcessAudit. When I press the Test button I get the message “Test successful”.

So far so good right ?

Well for some reason when I try and view my server error logs (view the web admin client) I get an exception, and the rows in the WMERROR table do not appear. I know there are rows in this table since I ran my own SQL query.

I decided to give the native Microsoft SQL Server 2000 Driver a try, so I setup a new Driver alias and used the class com.microsoft.jdbcx.sqlserver.SQLServerDataSource
and then setup a new pool alias using this driver alias. Here’s the new pool alias I setup:

Alias Name: WaynesTestAlias
Associated Driver Alias: Microsoft SQL Server 2000 Driver
Database URL jdbc:microsoft:sqlserver://AUG-SQL70\AUGSSQL12:1433;databaseName=wmaudit;SelectMethod=cursor
Minimum Connections 1
Maximum Connections 40
Idle Timeout 60000 milliseconds

I associated the new pool alias to the ISCoreAudit and ProcessAudit Function Names.
I then restarted the Integration Server.

I can now view the information in my Audit, Error, Server and Session logs via the web admin…HOWEVER if I try to Test the function alias definitions using the new pool alias I get the error:

Test of <function> Failed
No suitable driver

Any ideas ? Note: the ms*.jar files are in my Integration Server \lib\jars folder.

Is it “better” (recommended) to use the Microsoft drivers for SQL Server or the DataDirect drivers ?

Regards,

Wayne

A follow-up to my post above…
Here’s the error I get when I use DataDirect Connect JDBC SQL Server Driver:

com.wm.app.audit.AuditException: [BAA.0002.0000] Wrapped Exception: java.sql.SQLException: [wm-cjdbc32-0014][SQLServer JDBC Driver]Request cannot be submitted due to wire contention.

This error appears when I try to look at the Error logs via the web admin.

Wayne

Hi Wayne,

It’s been a while since I’ve used the SQLServer with IS6, (now using Oracle at the client) but I notice one difference in my old onfiguration of the Microsoft shipped JDBC Driver - the Database URL:

jdbc:microsoft:sqlserver://geelvis;DatabaseName=Xref
(Note the uppercase letters in “DatabaseName”)
Don’t know whether this is significant but give that a try.

At that stage I had to create my “own” driver config file to add the Microsoft JDBC Driver to the default set shipped by wM - these can be found in the <installdir>\IntegrationServer\config\jdbc\driver directory
I attach my driver definition file just in case

wM IS6 config file for “Microsoft SQL Server 2000 Driver for JDBC”
Microsoft SQL Server 2000 Driver for JDBC.xml (0.5 k)

I preferred the Microsoft shipped JDBC Driver for SQLServer as one could also use it for non wM DBs, unlike the DD Drivers which required some extra licensing.

Would also be interested to hear if there are any performance differences.

Regards
Danie

I tried to create a connection to SQL Server 2000.
The jdbc driver is DataDirect JDBC Connect 3.3 and the jar files are in the class path:
D:\webMethods\IntegrationServer\lib\jars\base.jar
D:\webMethods\IntegrationServer\lib\jars\sqlserver.jar
D:\webMethods\IntegrationServer\lib\jars\util.jar

But for some reason, I am getting this error when enabling this connection in the config tool:

Error encountered
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource connection:ABIPunchOut.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.205] Cannot retrieve the metadata. "
(HY000/0) [DataDirect][SQLServer JDBC Driver]This driver is locked for use with embedded applications."
[DataDirect][SQLServer JDBC Driver]This driver is locked for use with embedded applications.

This jdbc driver is licensed separately from the embedded DD driver.

Anyone else comes across this? pls advise if there is a workaround.
Thanks,

Jake

hello professionals,
I am trying to configure JDBC pools.
for driver alais i given following parameters:-

Alias Name: DataDirect Connect JDBC SQL Server Driver
Alias description: webMethods DataDirect Connect JDBC OEM driver
Driver Class name: com.microsoft.jdbcx.sqlserver.SQLServerDataSource

for JDBC connection pool alias:

Alias name: DataDirect Connect JDBC SQL Server Driver
Assosiate driver alias: DataDirect Connect JDBC SQL Server Driver
database url: jdbc:sqlserver://172.17.3.104:1433;databaseName=mirmethods;SelectMethod=cursor
Min connections: 1
Max connections: 10

while restarting the function ISCoreAudit, i am getting following error.

Restart Function ISCoreAudit Failed
[wm-cjdbc32-0014][SQLServer JDBC Driver]Error establishing socket. Connection refused: no further information

Can any one help in regarding this.

with regards

WM folks,
I was successful in loading SQL Server 2000 driver for JDBC and I can see that all my test runs for ISCore Audit/Process Audit/TN/Xref were successful. However, when I try to open my TN console, I get

[“Error Connecting to Server” (Check that server specification is correct and that server is running and accessible" )].

Before my driver was functioning well, I used to get error message such as "TN DB failure!)

How do I bypass this as my driver seems to be working fine as mentioned in the earlier case. Your help is greatly appreciated.