JDBC Adapter 601

Does anybody know if this adapter is available and the location of it? It does not show on the instaler and I cannot find it on the advantage site.

Thanks

It is definitely there on the installer.

Docs for the webMethods JDBC Adapter 6.0.1 can be found on Advantage under Bookshelf -> Adapters -> JDBC or by logging into

http://advantage.webmethods.com/cgi-bin/advantage/main.jsp?targChanId=-536883003

If it does not show up when you run the webMethods Installer, you may need to contact keymaster@webmethods.com.

While you are installing, please make sure JDBC Adapter is selected for installation.

This is the one of the default adapter component which installs with the V6.0.

Please go to the webMethods6\IntegrationServer\Packages\WmJDBCAdapter\doc to look at the JDBC Adapter documentation after Installation.

Hi Luis,

If the JDBC adapter is installed, go to IS and then

Adapters --> JDBC Adapter

If you dont see this option

Go to Packages --> Management and then look for the WmJDBCAdapter package, check whether this is enabled or not.

If you could not do none of the above, while the software installing in the very first window (you might have missed selecting the following option)
IntegrationPlatforms --> Adapters --> webMethods JDBC Adapter

i have the jdbc adapter, i have oracle installed on the system where the Webmethods is running, Now what will be the driver name??? i kept Oracle,seems weird but please help me out, and when it asks for the URL name what should i give i.e for example the database is in c://data/users.dbf
Please help me out

Please refer the following Configuration values, which are working for me to connect to Oracle…

Connection Type JDBC Adapter Connection
Package Name - JDBCTestServices
Connection Properties
Transaction Type - LOCAL_TRANSACTION
DataSource Class - oracle.jdbc.pool.OracleDataSource
serverName - Give Your machine name, where Oracle Installed
user - scott
password - ******
databaseName - ORCL or SID
portNumber - if default 1521 or give the port number where
TNS Listener is.
networkProtocol - leave blank

Other Properties - driverType=thin

Connection Management Properties
Enable Connection Pooling true
Minimum Pool Size 1
Maximum Pool Size 10
Pool Increment Size 1
Block Timeout (msec) 100000
Expire Timeout (msec) 100000

Thanks,
-GV

I installed JDBC adapter 6.0.1 on wm6.0.1 IS. Created a JDBC connection (LOCAL_TRANSACTION), and a simple JDBC adapter service. I tried to use explicit transaction.

my flow looks like this:

pub.art.transaction:startTransaction
<jdbc>
pub.art.transaction:commitTransaction

I got error in startTransaction. On the console I saw this error message:
2003-05-16 15:28:04 EDT [ISS.0015.9998E] Exception --> com.wm.pkg.art.error.DetailedServiceException: [ART.117.4036] Adapter Runtime (Adapter Service): Unable to rollback transaction. Transaction state:Transaction is active .

Implicit transaction works fine.

Any idea?

Thanks,

Bin Wu

Bin Wu,

Just want to make sure…have you given the transaction name in the Start Transaction and are you using the same transaction name for your commit and rollback?.

I used to get similar error and after giving the transaction name this error was gone.

Uday

How to configure the JDBC Adapter for SQL Server 2000. Has anybody tried this before?.

I am seeing a problem while using the DataDirect SQL Server JDBC driver, available in the lib folder of the IS601.

I see an error "Unable to configure manager, JDBC DataSource Class name “com.ddtek.jdbcx.sqlserver.SQLServerDataSource” cannnot be found while trying to enable the JDBC Adapter configuration.

Thanks
SS

Sharath:

Check JDBC driver jar file is in IS CLASSPATH.

you can see classpath in Administrator screen “About”.

Hi,

I’m getting this Error when trying to use a notification stored procedure on a Sybase datasource: “[stored procedure name] may be run only in unchained transaction mode. The ‘SET CHAINED OFF’ command will cause the current session to use unchained transaction mode.”

Anyone have any idea on the cause and solution for this issue?
I’m using LOCAL_TRANSACTION as the transaction type for the JDBC Connection!

Best Regards,
Gonçalo Santos

You can use sp_proxmode to set the stored procedure to ‘anymode’.
Refer to http://webforums.sybase.com/nntp/nd000041.nsf/0/24528f5ab1e39456df8abdc18bd599cf?OpenDocument for more help info.

Hi,

I’m implementing a notification to retrive values from a stored procedure in
a sybase 12 Database.
This is a migration project from an early version of webmethods 3.1 with
standard DB Adapters.

The problem I get is that, within the stored procedures’ workflow, some
temporary system tables are created and some insert and updates to other
tables are done.
This creates an error in the JDBC Adapter with a LOCAL_TRANSACTION
connection.

I have to use LOCAL_TRANSACTION to ensure the processing.

I’ve tried to commit the transaction at the begining of the workflow service
that reports to the Document Type Reference of the notification, and start
transaction at the end of it. The error persists.

Can anybody help?

Best regards,

Gonçalo Santos

Hi,

I am using webMethods 6.0.1,Sybase SQL Anywhere Studio 8.0.2 and JConnect 5.5 JDBC Driver. In the documents no where webmethods mentioned that webMethods 6.0.1 supports Sybase. I am able to Connect to the Sybase Server 12.5 using the WmDB Package.Through services it is working fine.

I am trying to configure the JDBC Adapter to connect Sybase Server.
I am getting the following error while enabling the Connection.

Error encountered
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource SybaseFolder:Test.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.204] Cannot connect to the database with DataSource class “com.sybase.jdbc2.jdbc.SybConnectionPoolDataSource”.
JZ0S3: The inherited method getConnection() cannot be used in this subclass.

Can anyone tell, what would be the problem?

Thanks in Advance.
Thota

Thota,

The JDBC Adapter 6.0.1 only supports Oracle and SQL Server databases at this time. Your working connection through the WmDB services is the only way to go at this time.

Steve

Hi Steve,

Since WmDB package was deprecated, my client doesn’t want to use the same. I got the info from webMethods support team that they will support Sybase in the next quarter.

Cheers,
Thota

Did any of you encountered such an error while creatign a service under the XATransaction mode,

enlist failed: oracle.jdbc.xa.OracleXAException OracleSQLError = [-1] OracleError = [65535] XAError = [-3]

Any help is appreciated.
Thank you in advance

-Vijay

Hi all,

I’m a WebMethods newbie and I’m trying to configure a JDBC Connection to an Orable DB. And after editing all parameters I’m obtaining the next error:

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource Connection:TestConnection.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
com/ddtek/jdbc/extensions/ExtEmbeddedConnection

This is the configuration I’m using:

Transaction Type : LOCAL_TRANSACTION
DataSource Class : oracle.jdbc.pool.OracleDataSource
Other Properties : driverType = thin

I’ve also tried the “oracle.jdbc.pool.OracleConnectionPoolDataSource” class, but I obtained the same error.

Does anyone knows what I’m doing wrong?

Thanks in advance,

Ignasi

Hi Jin

Check for the right data source class. It have to be:

com.microsoft.jdbcx.sqlserver.SQLServerDataSource