Issue with SOAP webservices in webmethods API Gateway

Hello everyone,

Our organization is currently using Webmethods API Gateway version 10.11.0.8.192 and Software AG Command Central 10.11 our environments.

Case #1: I have created a new API with WSDL type (SOAP webservice). After creating it and clicking on it to edit the API, I am getting the following message:

and when I try to delete it, nothing will happen.

NOTE: I have the highest privileges on this environment.

Case #2: I have tried to onboard another SOAP webservice, and when I try to activate it I get the following message:

However, I was able to delete this webservice.

My questions are:
1- How can we delete the SOAP service?
2- How can we activate the SOAP service?

your help and assistance are highly appreciated.

Abdulaziz

I have found a solution for both cases mentioned in this post.

for Case#1, restarting the command centeral and then I was able to delete the webservice.
And for Case#2, changing the type of SOAP from 1.1 to 1.2 fixed it.
image