[ISS.0084.9001] Invalid credentials <h4>Access Denied</h4>

Guys,

The below exception is thrown while trying to insert the data in DB through Portlet that was created through designer.

electric.util.WrappedException: java.rmi.RemoteException: HTTP error response: [ISS.0084.9001] Invalid credentials

Access Denied

at com.webmethods.caf.wsclient.proxy.impl.WSClientDynamicProxy.getCompatibleException(WSClientDynamicProxy.java:411)
at com.webmethods.caf.wsclient.proxy.impl.WSClientDynamicProxy.invoke(WSClientDynamicProxy.java:227)
at $Proxy26.insertServerListDetails(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at com.webmethods.caf.faces.data.object.ObjectMethodContentProvider.refresh

Do someone have a solution for the above issue?

Appreciate your speedy response.

Regards,
Magesh

Did you get the solution for this!?

Hi Magesh,
I’ve came across on the readme of the Trading Networks 7.1.2 and found that the below settings need to be used in “Extended Setting” in the Integration Server if the MywebMethods Server is not running on the default port(8585).

watt.server.auth.samlResolver=http://host name:port/services/SAML

Please try if that helps.

Hi Magesh,
I’ve came across the readme of Trading Networks 7.1.2 which says that the below setting needs to be added to Extended Setting of the IS if the MywebMethods Server is not installed in the default port(8585).

watt.server.auth.samlResolver=http://[FONT=Palatino Linotype,Palatino Linotype][SIZE=2][FONT=Palatino Linotype,Palatino Linotype][SIZE=2]host name:port[/size][/font][/SIZE][/FONT]/services/SAML

Please try this out.

Hi All,

I was facing the same issue. In our environment MWS is running in default port - 8585.
Though I have added below settings in Extended settings it didn’t resolved the issue.

watt.server.auth.samlResolver=http://host name:port/services/SAML

Then I found that, SAML assertion in the server-config.wsdd file was missing. You can see this file under folder /MWS/Server/default/deploy/portal.war/WEB-INF.

Add below SAML assertion in server-config.wsdd file and restart MWS, it will resolve the issue.

Regards,
Suresh Rao

Hi All,

We are also facing the same issue in MWS when ever we click on any B2B links in MWS , error as below:

electric.util.WrappedException: java.rmi.RemoteException: HTTP error response:

Access Denied


at com.webmethods.caf.wsclient.proxy.impl.WSClientDynamicProxy.getCompatibleException(WSClientDynamicProxy.java:398)
at com.webmethods.caf.wsclient.proxy.impl.WSClientDynamicProxy.invoke(WSClientDynamicProxy.java:214)

We have all the SAML configurations in place still we are facing the issue.

Any one know about this issue and the solution please suggest me.

Hi Veena,

Reason is your TN Server is not configured properly in MWS. Follow below debug point

->Check whether Centeral User management should be “Configured”. if not,first configure Central User Management and restart IS
->Now make sure correct TN server is configured in MWS

Doing above steps all B2B links should work fine

Hi Sai,

Thanks for the replay.

The configurations u mentioned are already configured in IS and MWS servers.
Still I am not able to see the B2B transations and getting the same error as “HTTP error response:

Access Denied

We are using IS and MWS versions 7.1.2.
Could you plz suggests me if any configurations are missing.

Check whether SAML service is running correctly on MWS

http://:8585/services/SAML?wsdl

if you did not get a responce there a problem with SAML component

Hi,

I am getting a response from SAML in xml format.

Debug point

1)Set following parameter in extended setting of IS

watt.server.auth.samlResolver=http://hostname:port/services/SAML

If above property is already set, Reset it and restart server

1 Like

Hi Sai,

We have checked this in extended settings as well -

watt.server.auth.samlResolver=http://hostname:port/services/SAML

That is set properly, even then we are facing this issue.

Could you please provide us some other alternate solution on the same isue.

Regards,
Shivangi

Have tried these steps

1)Remove watt.server.auth.samlResolver=http://hostname:port/services/SAML property
2)Restart Server
3)Set property again
4)Restart again

Is it working earlier? what has happened? any updates made on server?

Have you try to restore your server from existing backup tape!!

Have you tried to delete repository files and restart server?

Hi Sai,

We had upgraded JVM version in all servers from 1.6.0.8 to 1.6.0.11, but it did not support MWS servers. It caused this issue, and now even if we have reverted back to previous version, the issue still persists.

We have tried everything suggested by you but still not able to resolve the issue.

Regards,
Shivangi

Hi Shivangi/Veena,

Good day to you.

Is your issue resolved ?

If not go through the below steps and make sure everything is fine…

  1. CenteralUser jdbc pool has to be configured to look at MWS DB schema
  2. Role in MWS has to be created MWSMonitorUsers which has your Business users group from AD as members. Also it means that AD look is working fine as it allows us look up AD groups/users and add as a member to MWS Role.
  3. Using MWS Permissions Management set role MWSMonitorUsers to view Monitoring pages and also start/stop/suspend/resubmit process/service/documents etc.
  4. In IS ACL MonitorUsers has to be assigned to above system\MWSmonitorUsers role.
  5. SAML URL has to be configured and is pointing to right MWS.
  6. Log in as Sysadmin to MWS and navigate to Folders > System > Managers > command > dir .Click on authenticateuser and set authenticate to true.

If all the above configurations are perfect then check the FIX levels of your server and update them with the latest releases. It should work.

Best Regards,
Venkat.

Hi Venkat,

Thanks for your replay,

We have all the configurations in place in our environment, still we are not able to open any of the B2B Links.

Hi Veena,

It seems you have problem from long time and non options worked

I have couple of suggestions

  1. Restore your system to last good state you know

  2. Approach SAG for better resolution

Hi Veena,

Once we faced such problem like we were unable to access the B2B functionality.

We followed the below resolution and it worked.

Changed the listener host address in IS in the file “tangasol_coherence_override.xml” under the folder…

webMethods/IS/config/caching/tangasol_coherence_override.xml .

Change the listener section by replacing the hostname with IP address ( IS IP).

Once after changing restart the server.

You can give a try …

Best Regard,

Venkat.