Invalid user ID

NJX appears to run fine under WinXP, but fails under SLES10. What have I overlooked?

Comparing session definitions side-by-side with the NJX Configuration Tool, they’re substantially the same, but with SLES, the Logon to Natural page displays “Invalid user or password” from Natural, and “Logon to server failed” on the status bar.

NWO logs the following (of course, I’ve overwritten the user ID):

%NWOSRVD-I: 17.06.2009 23:06:16 Processing a new connection
%NWOSRVD-I: 17.06.2009 23:06:16 Client details:
                        Client type = Rich GUI J2EE
                        Protocol version = 4010101
                        Compression type = No compression
%NWOSRVD-I: 17.06.2009 23:06:16 Start packet received:
                        User name        = ????????
                        IP address       =
                        Application      =
                        Parameters       = STACK=(LOGON SAG;SYSVAR;FIN)
                        Language         = 1
                        Physical rows    = 24
                        Physical columns = 80
%NWOSRVD-E: 17.06.2009 23:06:16 Invalid user or password
%NWOSRVD-E: 17.06.2009 23:06:16 nwoProcessNaturalStartPacket fails.
%NWOSRVD-I: 17.06.2009 23:06:16 Connection processed

I’ve specified every user ID that I can think of, always with the same result. Even ROOT fails.

Under XP I use a standard Windows user ID and password.

What user ID and password should I be using under SLES?

Hi Ralph,
I had the same problem on SLES10 some months ago.
I solved it by creating a nufesrvd-file as described in servline24 DocID 551524.

[i]- create a new file called “/etc/pam.d/nufesrvd”

  • add the two lines between *** to nufesrvd

auth required nullok
*** [/i]

Hope this helps

Yes, that corrected the problem.

Thank you.