[installed a wmVCS] Cannot delete package in designer

Hello , experts…

i have one question
i cannot delete package in designer.

situation step

  1. Selected a packages in package Navigator
  2. Click Right button of mouse and Choose Delete
  3. Contents inside the package is deleted.
  4. But Package is not deleted
  5. That only the package > number 2 step retry

Delete Error : Count not delete package
Details : java.lang.NullPointException ( Notting to ohter messages)

However…
when i restart the Integration Server … that disappared.
Without restart the Integration Server , i want to immediately delete to package in designer ( package Navigator )

please answer
i want recommand that even hint

best regard

While you delete the package from the designer have a look at the server.log and share the log details to assist you better.

You can also delete the package from the IS admin console, Packages >> Management

Hi Yeom,

which version of wM are you using?

Which VCS-System (incl. Version) are you using?

Regards,
Holger

Dear, M@he$h

I have another questions.

when i deleted in “Packages >> Management”, situation was not only changed but also screen just kept refreshing without action.

Plus, designer was also not changed.


Dear,Holger von Thomsen

Sorry, the version i use is 9.7

thank you for answer !!!

Are you using any customized VCS system, also after deletion of package from designer did you refresh it ?

Thanks,

MR as173d

i am not used to Custom VCS also i can many refresh in designer :frowning:


Hi Yeom,

which VCS-System (incl. Version) are you using?

Can you share some screenshots which show the exact issue?

Additionally which Fixes are applied especially for WmVCS-Package as well as the corresponding VCS-specific package?

Regards,
Holger

HI Holger von Thomsen

–ERROR MSG–

2015-12-18 14:47:28 KST [ISS.0028.9998E] Exception --> C:\SoftwareAG97\IntegrationServer\instances\default\packages\DUAWOFUD (??? ??? ?? ? ???)
2015-12-18 14:47:44 KST [VCS.0132.0001E] ERROR: message: [ISS.0132.9117] error running command [svn, delete, --username, Administrator, --password, ********, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\code, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\code\classes, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\code\jars, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\code\source, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\config, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\config\CSRFLandingPages.cnf, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\lib, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\manifest.v3, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\ns, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\pub, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\pub\favicon.ico, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\pub\index.html, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\resources, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\templates, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\templates\README.txt, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\code, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\config, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\pub, C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\templates, --force]; exit value: 1; output: [svn: E155007: ‘C:\SoftwareAG97\IntegrationServer\instances\default\packages\Default\code’ is not a working copy]

(??? ??? ?? ? ???) <- can not find the specified file

it is log , when i delete packages in designer.
and is not view, another obejct in packacge navigator
I don’t know why try again. it is delete contents!

Q: Additionally which Fixes are applied especially for WmVCS-Package as well as the corresponding VCS-specific package?
A : i can not find wmVCS fix So not instail wmVCS fix . you want is answer?

Regards

May be can you try this and see if it resolves?

Cleanup the repository files (of course all the package locks will be gone) but before you remove always take a back up of the repo files.

Please make sure you shut/restart IS:

HTH,
RMG

You should not be deleting the Default package in the Integration server. As far as i know, If the Default package is not in your repository you can not use SVN to delete it(i believe when configured for VCS, Designer uses SVN command by default to do those operations).