InfraDC configuration


I have read the Optimize documentation several times now and looked inside advantage but still I have not understood exactly how (if necessary) to configure InfraDC.

Basically the Optimze environment is set correctly through the Central Configuration (MWS) on my setup. In my particular environment I had to change the InfraDC port to 5554 (I have an IS on the default 5555 already).

When looking inside MWS or Central Conf. I do not see a “place” to tell what is the new InfraDC port.

Nevertheless I did a small test where I added a new asset and indicated the IS where to look for. Apparently data is being collected as expected but on the “Assets to Discover” portled and DATA COLECTOR column I see “InfraDC@myhost:5555”.

Note: myhost is running an IS(5555) and a InfraDC (5554).

I am a little bit confused because I cannot set the new InfraDC port anywhere, the chosen monitored component seems to be working fine and the “label” (I guess it’s a label) on the DATA COLECTOR column indicates that the InfraDC is on 5555 (whitch is wrong it should be 5554).

Any ideas about the actual configuration of InfraDC are very appreciated even if it seems very simple or obvious. I seem to be skipping a very obvious fact.


Luis Cordeiro

It’s been a while since I configured Infra DC, but I don’t believe there is a specific location in the environment (like the endpoints you map for AE) for Infra DC. MWS doesn’t keep an eye on it like it does the WSDC, AE and PE. Instead, you’ll want to configure an objectStatus KPI for the InfraStructure DC monitored component.

Also, Infra DC’s config is done through the InfraDC administration console - http://:5554 in your case. Make sure your JMS queue settings are correct, so that messages can get to the Broker (or whatever JMS provider you are using.)

Thank you for your reply.

An additional question, if InfraDC is not configured then (or at least the new host port) how do the monitored components know about it? (if they really need to to know?!)

I am clearly missing some point of the way InfraDC works in the scope of the Optimize products. I guess all the data is pushed from a certain monitored component into InfraDC (using SOAP??) and the it goes to the broker to the Analytical engine. If this is correct then when configuring and Asset (and thus the monitored component) I would imagine (because credentials are asked on the MWS portlet for the target IS) that some sort of destination address is sent with info about InfraDC.

Now if monitored components seem to push data, then on the MWS portlet the indication that it’s “InfraDC@myhost:5555” (DATA COLLECTOR)… seems wrong.

How did MWS found I had InfraDC there (on that host and port)… could it be through a broker message… the host is actualy correct but the port it’s the original one. On myhost:5554 I configured the JMS endpoint correctly.

This may well be all wrong :lame:

Thanks again,

Luis Cordeiro

Let me see if I can knock off some of the rust I’ve accumulated on my Optimize knowledge - those with more recent experience please weigh in.

For Opt4Infra, it is a collection from agents installed on the various webM components (thus the polling interval you can configure in the Admin console).

Actually the InfraDC has a number of internal collectors: a Broker Server collector data module, an IS collector data module, a sSNMP data collector module, an IDC collector module, and a common data collector module. The common data collector gathers information from all the others and uses the API to send information to JMS queues, where it is gathered by the analytic engines.

As to why it is already there in the monitored components list? I would assume for the same reason all of the pre-defined rules and KPIS show up there - they are either added at install time or the first time the InfraDC is run.

The InfraDC log show this:

[180]Timestamp: 1221691035350
[179]EncryptionStrength: null
[178]TrustStoreType: jks
[177]TrustStoreFile: null
[176]KeyStoreType: pkcs12
[175]KeyStorePassword: null
[174]KeyStoreFile: null
[173]UseSSL: false
[172]Password: *******
[171]UserName: Administrator
[170]ConnectionState: Accepted
[169]MonitorPort: 6850
[168]Port: 5555
[167]Host: myHost

[166]DataCollector: InfraDC@myHost:5555
[165]Type: Integration Server
[164]Name: bam:5555
[163]ID: 0
[162]2008-09-19 17:02:24 BST [ISU.0000.9999D] com.wm.datacollector.asset.AssetProviderImpl:

My interpretation of this InfraDC log is:

  1. The InfraDC “name” is InfraDC@myHost:5555. This is just a name (although the actual InfraCD port is 5554). It must be some sort of initial setting… I wonder if InfraDC was started the first time with the correct port…

  2. InfraDC receives the relevant data (coming from MWS Monitored Components portlet). The included the host, port, credentials of the IS where the service to be monitored resides. This must be done through the broker.

  3. InfraDC polls the data from the monitored IS and not the contrary (IS pushes to InfraDC).

This explains why I did not configured anywhere on MWS the new InfraDC port and nevertheless everything works fine.

If anybody has some details on this I think it would be important for future generations :kiss:

Luis Cordeiro

Hi All ,

  Please go to the C:\web7\InfrastructureDC\config\ and open infradc and change the data collector name to what ever you want it sjould display in the MWS

Thanks and Regards