I'm not able to connect to IS from MWS

I have installed IS 9.7 and MWS 9.7 in the same server.
Fix levels are the latest(core fix4).

  1. IS: http://localhost:5197
  2. MWS: http://localhost:8597
  3. MWS SAML Resolver URL in IS Admin> Resource: “http://localhost:8597/services/SAML
  4. My webMethods > System Settings > Servers
    • INTEGRATION SERVER (MONITOR) HOST: localhost
    • PORT: 5197

When I click “Check Server Status” in MWS, it failed and I see following error in IS log.
[ISC.0088.0001E] SOAPException: [ISS.0088.9125] SOAP request does not conform to the SOAP message model.

I tried to add another IS(also 9.7 with core fix4) in local MWS and it was able to connect to the IS successfully, which means my local IS has an issue.

Please advise what point i should check.

SJ – Is you server status showing red signal? then check whether you have installed WMmonitor and configured it properly or not.

The WmMonitor-Package has a page for editing the connection parameters to the MWS-Server.
This page is accessible via Packages -> Management. See the WmMonitor-Package and click on Homepage Icon.

Yes, server status is red and I’ve already set WMmonitor as shown below which are same as another IS’ WmMonitor setting. Is there anything else I can check?
-. MWS Host: localhsot
-. MWS Port: 8597
-. MWS Transport: http
-. MWS Username: Administrator
-. MWS Password: manage
-. Database Retries: 3
-. Enable Data Level Security << unchecked
-. Data Level Security Administrator: Administrator
-. Reporting Batch Size: 100
-. Enable JDBC Archive for Server, Service, Activation, Document << unchecked
-. Add ‘My webMethods Users’ role to ‘MonitorUsers’ ACL<< checked
-. Resubmit to local IS << checked

What is your Monitor Fix Level (IS and MWS)?

Please try to use another address of your box instead of localhost.

There seems to be an known issue related to localhost.

Regards,
Holger

Holger,

I’ve already tried with ip address, but it didn’t help.
I installed new IS and applied samw fixes. MWS was able to connect t. this new instance.
It’s very strange.

Hi All,

I’m facing issue while check server status from MWS and IS is not getting connected.

The error log it is writing in IS server logs is below

[220]2019-11-26 16:43:48 UTC [ISS.0012.0012E] Authentication of user “null” failed with exception: com.wm.app.b2b.server.ServiceException: OSGi service for SAML authentication not initialized…

Resources - Single Sign on setting is pointing correctly -MWS SAML Resolver URL

Any help in this regard is much appreciated.

Hi Firoz,

is the Central User Management in IS configured correctly?

Is the WmMonitor package correctly configured?

Regards,
Holger

Hi Holger,

Yes the central user configuration and WmMonitor configuration is correct.

Once I restarted the Integration server it started connecting, not sure if WmMonitor reloading didn’t take effect, I expect it to do so.

This issue is resolve. If it happens again, may be I will go with restart.

Thanks a lot for your response.