HTTPS Keep Alive Timeout Value Setting

I have configured a HTTPS Port in webMethods Integration Server 7.1.2 and I realized 2 new parameters introduced in this version called Backlog and Keep Alive Timeout. I would like to set the Keep Alive Timeout setting value to be infinite rather than the default value, 20000 ms (20s).

Please help.


That’s a bad idea, but then set the value to 0.

Why a bad idea? That values does:

“This value will cause the connection to be retained for possible reuse until it times out.”

A remote attacker could open connections, not release them, and use all the threads in the Threadpool port, getting the port unresponsive.

But is your option :smiley:

Thanks DevNull43 for the reply and advice.

How webMethods 6.5 handling Keep Alive Timeout since this parameter is not exist?


0 is not mends for infinite in this case. :frowning:

Screenshot is attached.

I have set 5minutes to be the interim solution.

Please help.
Regular HTTPS Listener Configuration.JPG

It makes no sense either way to have a infinite value here, so +1 for not using it :smiley:

Ok lets see, if I can explain.

You need to take into account the difference between TCP keep-alive and HTTP keep-alive feature, they are NOT the same.

IS 6.5 did support only HTTP 1.0 when acting as a server (This is when you define a port), and some HTTP 1.1 when it was the client.

IS 7.1 supports HTTP 1.1.

The keep-alive setting is part of HTTP 1.1, so that’s why IS 6.5 did not have this setting.

What does HTTP keep-alive do? Please check

Also notice Apache advice on this setting:

That’s why my advice was not to set a infinite one.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.