java.io.IOException: java.net.ConnectException: Connection timed out: connect

Hi All,

We are trying to call a HTTPS URL from Webmethods using pub.client:http
It is throwing this error : java.io.IOException: java.net.ConnectException: Connection timed out.

But the same URL when accessing in browser, it is working. Any suggestions what might be causing this issue here.

Below is the URL details :
https://hostname/ReinsDefects/Reins/CallAPI.aspx?HouseName=“12”&Address1=""&Address2=""&City=""&Postcode=“CF3”

This gives response as ‘yes’ or ‘no’ . From browser, this is working but WM throwing error.

Hi Sangamesh,

are you invoking via Browser and via service from the same box?
Can you check with traceroute or ping if the request takes the same time to get answered approx.?

You might want to try to tweak the timeout parameter for the https invocation in your service to see if anything changes.

Regards,
Holger

In addition;
Do you have a proxy configured in your browser that your haven’t in your Integration Server ?
John.

1 Like

In addition to the excellent points above, I find these diagnostics useful:

  • OpenSSL SSL client: Use command format: openssl s_client -connect <hostname>:<port>
    (for example: openssl s_client -connect example.com:443
    This command is also able to use client certificates.
  • Curl
    (for example, curl https://example.com:443 -v)
  • Easily verify IS can connect to a third party. You simply invoke pub.client:http via your web browser and point it to the remote website
    (for example, http://<IS>:5555/invoke/pub.client:http?url=https://example.com:443&method=get)

The first two tools (openssl and curl) must be run from the command line, after logging into your IS box. There are versions available for both Windows and Unix.

1 Like

Hi Sangamesh,

Can you check whether the timeout parameter have been set in your the pub.client:http?
If no, make sure watt.net.timeout server configuration parameter had set, because if you do not specify a value, Integration Server will uses the value of the watt.net.timeout server configuration parameter.

Thanks

1 Like