HTTP cloud proxy passthrough functionality

Product/components used and version/fix level:

Cumulocity Cloud
Microservice: Cloud-remote-access , Github-proxy
UI Extension: Cloud HTTP proxy Version: 2.3.2 in Device Managemant Application

Detailed explanation of the problem:

I am trying to install and use the “http cloud proxy” functionality. Followed the steps in
Github - cumulocity-remote-access-cloud-http-proxy
Have installed the Microservice and UI. RemoteAcces is runing and I can see the tab on the device level. I have a problem with the “Passthrough” option. Like in the description the “passthrough” is disabled on eu-latest.cumulocity. com and cumulocity. com. I have checked the system options and the “pass-through.enabled” value is set to “false”. So I can not see the option in the selection (only VNC, SSH). With REST I could import the configuration but it is not working. In the description when everything is set the new Tab (e.g. NodeRed") should appear. In my case it is not. The ThinEdge is setup like in the description and is connected to cumulocity.
Is it possible to use the “http cloud proxy” even if it is set to false in the tenant?

Error messages / full error message screenshot / log file:


Question related to a free trial, or to a production (customer) instance?

testing on “eu-latest.cumulocity. com”

Unfortunately it is still disabled on eu-latest to appear in the UI selection list (the key is only to make it visible).

Still, you can and should be able to add your passthrough endpoint using REST. How does your config look like created via REST?

In this guide it is explained how to add the endpoint using REST.


Did you follow this instruction:

The name of the configuration should be prefixed with either http: or https: depending on the server you are trying to connect to. This is used by the UI Plugin to identify endpoints that are compatible with it.

In case the tab does not show up, check the browsers console logs. In case you’ve missed to set a tenant option, you should see a warning there.

1 Like

Hello Stefan,
thank you for the information and the respond.
I have followed the description in the guide for remote-access.
My configuration looks like in the description:

If I use the SSH funktion it works and I have access to the device. The passthrough or proxy funktion doesn’t work. I didn’t get the Tab for NodeRed.

I only get this warning in the console:

Hi Valerian,

the UI was checking if this system option was set before showing the tabs.
I’ve just disabled that check now. With version v2.3.3 of the plugin you should see the tabs even if that system option was not set.


1 Like

Hi Tristan,
thanks for the update. I have installed the new version of the UI (2.3.3) but the Problem is still not solved the Tab doesn’t appear.
The warning in the console is solved. I also see this warning in the console.

I don’t know if this has effect on the functionality.

Hi Valerian,

can you provide a screenshot of the remote access configurations of your device?
You should be able get them from: /apps/devicemanagement/index.html#/device/<deviceId>/remote_access

Even better would be if you could provide the JSON response to the GET request going to: /service/remoteaccess/devices/<deviceId>/configurations


here is the remote access configuration:

the service/remoteaccess get the following reponse:

When you navigate to /apps/devicemanagement/index.html#/device/<deviceId>/cloud-http-proxy/5 does it work then?
Can you check if your device managedObject has a c8y_RemoteAccessList fragment?

The cloud-http-proxy microservice is up and running?

the problem was the microservice, somehow I had the wrong microservice running. I have subscribed the “cloud-http-proxy” now I can see the Tab with NodeRed. I could type in the Credentials for NodeRed but the display with the Nodes doesn’t appear.

the console has a warning:

Authentication through the cloud-http-proxy has only limited support. But the 404 looks like something else might be wrong with your Node-RED instance.

If I change to the NodeRED Tab I get a login Popup, when I enter my credentials it doesn’t work. I get the screen again and again.

In the console I also get:

If I connect to the IP localy I get the right NodeRED Visualisation.

Is your tenant configured for OAuth or Basic Auth? The plugin is only meant to be used with OAuth as stated in the README.
Please ensure that you have read the Prerequisits & Limitations section.

You might also want to provide the microservice logs when you are seeing the 500 error.

we use the OAI-Secure Authentication:

the microservice log is:

Hi Valerian,

I’ve adjusted the logging within the microservice slightly. Can you try v2.4.0 of the mircoservice and provide the log again?
Please send the log file directly to me, instead of posting it in this thread.


Hi Valerian,

as discussed via private messages, your issue was related to the login page that was configured for Node-RED.
As already mentioned in: HTTP cloud proxy passthrough functionality - #12 by Tristan_Bastian, the proxy has only limited support for authentication.

I’ve been able to reproduce this locally and was actually able to find a solution to make the login work.
Version 2.4.2 should allow you to perform the login as well.


1 Like

Hi Tristan,

thank you for the information and the solution. With the new Version of the microservice it also works on my tenant. Thanks for the investigation and your time to solve this.

Best Regards