How to update Universal messaging license with a new license.xml?

How to update Universal messaging license(10.5) with a new license.xml?

I am having the UM license.xml file. I would like to know how can I update my UM license.xml file with new paid license.xml?

UPDATE - licence.xml and not license.xml

Replace your existing license.xml with the new one, and restart UM.
Path - /yourInstallationFolder/UniversalMessaging/server/yourInstanceName/license.xml

KM

Thanks. Unfortunately now i m facing very strange issue and that is when I am uploading this new license file using mobaxterm, it not uploading and the file uploading progress keeps showing 0%. I don’t know why this is happening now. I am facing the issue first time.

This usually happens with ownership or permissions of the folders vs the account your logged in with, or UM has a lock on the license file (I’m unsure if UM actually does this for the license file).

  1. I assume you’re on Linux - Upload the file to your /home/yourUser folder and then copy it from there to the target location, via command line.

  2. If that also fails, then navigate to existing file via the file explorer on the left hand side of MobaXTerm, and double click it to open it in an editor.

Then, replace the contents of the existing file, with the new one manually via copy-paste, and then save it.

If you face an issue here, try shutting down UM before you perform the overwrite.

  1. If all else fails, then write to your system administrator to investigate why.

KM

Thanks. 1. This is also not worked. When I tried this the same issue comes.
2.This also not solved the issue because the file is in windows right now. To follow this step, the file must be in linux machine. Isn’t it?
So finally I have reported to Admin.
Thanks once again.

Hi, Km. I have successfully uploaded the file into the path-- yourInstallationFolder /UniversalMessaging/server/yourInstanceName /license.xml. And do the restart of the whole machine but still when I m starting UM server a note at the end is coming- The license is not detected.
I would like to tell you that this new license file earlier named as 00006xxx35_UniversalMessaging_Integration105.xml so I changed it to license.xml. Just to confirm is this happening due to this changing of name?

Can you rename it to “licence.xml” (with a c and not s) and try?

KM

1 Like

Thank you very much. The issue got resolved successfully.

Great - you can close this post, by marking one of the replies as a solution.

KM