How to install and configure Broker 61

Can someone walk me through the install and configure of the default broker that comes with 6.1?? Here are the steps I’m following:

  • In WM installer, choose “webMethods Broker” under Runtime Environments. Only checkbox under that is Java API Runtime 6.1.0. I am choosing the relevant IS and TN options as well.
  • Startup IS.
  • Broker is currently not configured.
  • Go into webMethods admin, choose broker under Settings
  • Configure Broker connection to connect to port 6849 on the same server IS resides on. Use default name, group, prefix, Cert name, Password, Client Authentication are NULL. Restart server.
  • When I startup I get “Error ‘java.net.ConnectException: Connection refused: connect’ was reported by the socket call.” errors. Ive tried using localhost and the exact IP the IS server is running on. No luck.

I also cannot find the WmBrokerAdmin package anywhere on my system. Uninstalling broker and reinstalling means I have to also uninstall IS which I want to avoid. At a loss as to what’s happening.

Can anyone point me in the right direction??

I also dont have a broker directory under IntegrationServer in my folder structure…

If you uninstall and reinstall to the same directory, do all the settings from the old install get reused or overwritten by the new one??

Jim,

Broker should be installed in the webmethods_root\Broker folder. If it’s not there, you might have had a problem during installation.

If you installed it as an NT service make sure the service is started.

Also, you should be able to use the WmBrokerAdmin package to manage the broker if it is up, even if you haven’t yet configured your IS server to connect to it. Click on the home icon next to the WmBrokerAdmin entry on the Package Management page.

Mark

Thanks Mark,
None of that is there, no Broker sub directory and no WmBrokerAdmin package. I reran the install on my own machine and it;s the same thing. Can you confirm what the options should be in the installer for a full Broker install?? I only had the Java API Runtime checkbox available to me. I’m beginning to think we may not have that as part of our license agreement and I have a call into our sales rep to confirm.

Id appreciate it if you could run your installer and let me know what options you have for the Broker install so i can compare to mine. Thx

Jim

You should have webMethods Integration Platform -> RunTime Environment
-> webMethods Broker for selection during installation.

Stephen

Then something is wrong because when I select that option, nothing gets created as mentioned. No WmBrokerAdmin package, no directory created. This has occurred on 2 machines using the installer. Any ideas??

Remember that under webMethods Integration Platform -> RunTime Environment
-> webMethods Broker all I have is the Java Runtime API option… Should there be more???

Jim

I have the following components for selection

  • ActivX/COM API 6.0.1
  • C API 6.0.1
  • Documentation 6.0.1
  • JavaAPI Documentation…
  • Java API RunTime 6.0.1
  • JMS Provider 6.0.1
  • Program Files 6.0.1 <— That is the one
  • Service Pack 1
  • Tools 6.0.1

Thus, either your install image files does not contain the components
or your license problem.

Hope it help

Thanks for that Stephen, we do not have those under Broker in the installer which is why it’s not installed… I have our rep looking into our agreement which we thought included Broker…

Hi all,

I have the next scenario:

I have 2 Broker Servers with one default broker each one. I would like to join in the same territory the two brokers.

I’m having problems with the names of my Brokers Servers and brokers. The brokers servers are named the same : localhost. And I’ve been unable to change their default name. Is there some way to change the name of my Broker Server? And a way of changing the name of the default broker?

Thanks in advance,

Ignasi

Hi,
Can anyone help me on this?
When i start Integration server:i get a msg:“broker not configured”.
when i go to localhost…i click settings:broker-configure settings and i click configure and restart integration server.
i get the following errors:
‘java.net.ConnectException: Connection refused: connect’ was reported by the socket call

is it related to installation of “broker” during webmethods installation?
i dont have any directory names “broker” in the webmethods folder?
pls help me on this.

thks
regards
mallika

could you tell me which version you re using is it 7.1 or earlier version.

if it is eaarlier version you might not installed you Broker server properly

please check WmBrokerAdmin package is enabled or not.

hi
thanks for the reply!
I am using Webmethods Integration server version:6.5
Broker and manager of the same version.
Also when i am entering the license keys of the broker it says it has expired.
the WmBrokerAdmin package is enabled.
Is it related to the broker version tht i am getting tht error?
Thanks in advance
Mallika.

hi
Also can u let me know the latest keys for webmethods broker 6.5?
i think the problem is with the keys.
thanks in advance
mallika

License keys are provided to you by webMethods(SoftwareAG) not this forum.