Broker Starting Errors

Hi All,

I am not able to start my Broker. I installed it but i m getting following error. Please need help to solve it …

com.wm.installer.broker.ConfigurationException: An
error occured while creating the default broker.

Unable to open connection to host ‘localhost’.Error ‘java.net.SocketException:
Software caused connection abort: connect’ was reported by the socket
call.

Regards

Hello guys

i am also getting the same error what renuka is getting. i tried to reinstall the webmethods Integration server but while installing i was prompted by error related to Broker error and later at the last i got the same error what renuka has posted.
Plz need the help asap.
Thanks in advance.

Hi Rizwan First of all installing the webMethods IS doesn’t mean that you have installed the Broker Server. Try to install the Broker Server which would install the Broker monitor and create a default broker under that broker server.

For your senerio renuka tell me if you installed the new version of broker server on the old one and please some more information that how did you installed cause it seems like the error when installation of the broker server was not completed successfully

Hello Mr. Tallah

Thanks. I did installed all the packages come along with our CD. And i know i have installed broker also. I can see the Broker Package active and Installed Under Packages -> Management . But i cant see that package in Developer .
and also when i installed i got a message that broker cant be created at 6849 port choose any other port. I thing this is some thing related to Port No and Path.

So please could u please specify the how to resolve this path and Portno Problem.
It will be great help.

Looks like Rizwan your 6849 port no. is already in use somewhere, all you need to do is simply install the broker server on a different port. 6849 is the default port for broker server. Try to install it on 6852 or something and keep trying(increasing port no.) until you find the available port.
And by the way call me Talha its enough, Mr is too formal hehehe…

HTH