How to configure email settings for smtp service?

I want to send an alert email by using pub.client:smtp.
What are the resources and required configuration to do?

Hi Akash,

You can use the built in service pub.client:smtp (wM 7.1.2) and pass the below main inputs
1> mailhost
2> mailhostPort
3> auth (user and password) if it is a protected resource

Also have a look at the below links

Hi M@he$h,

            Here i am using pub.client:smtp service by providing the following input parameters.

            mailhost :

            mailhostPort : 465

            Provided to,from, and credentials. but it is continuously running....(infinite loop).

Hi Akash,

I am pretty sure that GMail requires a secure connection to connect via SMTP. I need to check on this 8)

Meanwhile you can try giving your corporate email, host and port. It should work :lol:

For Gmail, Configure Gmail SMTP password as: Your Gmail password.
Configure Gmail SMTP port as: 465 or 587.
Configure Gmail SMTP TLS/SSL required as: yes.

If you tried configuring your SMTP server on port 465 (with SSL) and port 587 (with TLS), but are still having trouble sending emails, try configuring the SMTP server to use port 25 (with SSL). But make sure SSL is active for SMTP in your email client. Also ensure “allow authentication” is active for the SMTP server in your email client.

Hi Tong,

Yes you are correct even I tried with gmail mail host, gmail id, password and all the 3 ports (one by one) but I was still unabel to send mails.

When I tried using the below parameters:

mailhost :
mailhostPort : 587
user: my gmail id
password: my gmail password

provided some test data in subject and body. When I run the service I got an error: Must issue a STARTTLS command first.

Do we have to do some setting/s for SSL or TLS under extended settings on IS admin page.

Please let us know.

Refer to webMethods Integration Server Built-In Services Reference documentation, there you will have all the information related to built-In services. You will see there any opcional and mandatory fields for that service and put this to work in no time.

If you still are unable to put this to work try another mail server, like corporate, Hotmail or make sure Gmail is not being blocked by your company.


Hello Akash,

You will not get this detail in any documentation. I have used the same using gmail as smtp host.
in addition to all the mail host and auth details. In the properties field you have to pass the below as name value pair input.

mail.smtp.auth true
mail.smtp.starttls.enable true

In the auth field use your own gmail userid and password. use the port as 465.
once you give these properties you will be able to use gmail as smtp host and will be able to send email.
Please find attachment for acreenshot. Let me know if you need further info.

Thanks and Regards
Abir Banerjee

1 Like