How EDIINT msg can process successfully even if asynch MDN fails to transmit via http

Hi All Guru’s,
I am having a issue with EDIINT process.

Issue number 1: When we try to send EDIINT messages to our trading partner(Cyclon server)via http, most of the time it goes through successfully but 10% fails with the error “ Read timed out”. But our trading partner receives the message successfully even we get the transmission error. We have never seen this issue in TEST environment.

Issue Number 2: When we send MDN back to trading partner for their original EDIINT message and if MDN fails to send for the same above error then original EDIINT messages also fails and it does not process the actual payload.
Is there a way to process ediint original message even if MDN fails to send? I checked with WM support and did not get positive reponse.

Product webMethods Integration Server
Version 6.1
Updates IS_6-1_FP2
Java Version 1.4.2 (48.0)

Any suggestions will be appreciated.



1 - Please make sure that you have enough Timeout limit on all of the firewalls (your’s and partner’s). It could be that your partner’s production system is taking a little longer than in the TEST to process and the firewalls are dropping the connection (assuming them to be stale)

2- Try Asynch MDN.


Thanks for your reply.

  1. ok let me check the firewall on both side.
  2. I am using the Asynch MDN but still the same issue.


I just spoke to WM and this seems to be way WM works, which defeats the purpose of having Async MDNs.
A work around would be to use synch MDN.
WM is going to get back to me on this one.

Actually I was using Synch MDN but it was failing for the same reason. After that WM suggested to switch to Asynch but got the same results.
I check with Network guys here and they said on firewall level there is no time out setting but we can filter the ip’s and do some more restriction.

Let me know if you find anything else.

FYI: I have built a process where it checks if
userstatus=ProcessMsg:ERROR then it reprocess the payload using processPayload service from EDIINT package. But this is not a permanent solution for the issue. I am running this process every one hour as a scheduler service.