Header and footer page not showing up in CAF page with sysadmin login

I have a webMethods MWS server, when I am logging in with sysadmin user the header and footer tab is not showing up.

Error page looks like this -

While the correct page looks like this from another MWS server -

Can someone help me how to fix this error?

Hi ,

I am even facing the same issue. And I need urgent help on this but I am not able to post a question so I am writing here.

Could some one please help urgently on this.

My MWS version is 8.2.


Maybe the shell rules are resolving to the blank shell?

Login as sysadmin and check your shell rules to compare what is there against a good environment.

Will you tell me the steps please? I am not very comfortable with CAF administrator.

Please refer to the Managing Shell Rules section of the MWS admin guide documentation.

If it helps you navigate to the admin portlet, you can load the address at [1] to force your current user session to use the powerdrill shell:

  1. http://[your_host:ports/?shell=shell.power_drill

Hello Eric,

After somehow i got to get administration guide.

But now I have got below problems:

I dont have administrator login for the server(Is there some default password that will be set for Administrator user)

And when I go to guide and see the steps below :

Administration > User Interface > Manage Shell Rules >…

I am not able to find User Interface when logged in as Administrator in the MWS which is working fine.

Under Adminiatration I can find below options:

My webMethods.

It will be really great if you could help me with the step in setting up the normal view for my MWS.

Apologies Anirban for using your post in asking my doubts, since I am not able to ask any question(could some one also help me with this as why am not able to post my queries please. I have posted one query already but, after that not able to)

Thanks In Advance for the guidelines provided here in working on the issue I m facing.



I have found the default pwd for sysadmin user now.

But I am not able to set the view. Even after comparing with the working one I am not getting much idea on this.(Working on this for the first time).

Could some one please help me with the steps in detail for setting the default view. I will be really grateful.


Hi Priya,

please login as sysadmin and check “manage shell rules” as well as “manage skin rules” for the evaluation order.
Checking “manage start page rules” might be another option.


Hi Holger,

I tried checking on those things.

For now I am able to work on the MWS with Administrator user( I changed the password for this user from Sysadmin profile). But for “monitoruser” I am still facing the same issue.

I am providing here the SS for the working one and the affected one.

I am able to see the difference in Guest Rule, but I am not sure how to set that. If it is possible could you please help me with that.

Please find the SS of Manage Shell Rules below:

I have compared the “manage skin rules” and “manage start page rules” and I don’t fine any difference. If required I can provide the SS of that as well.


Hi Priya,

the icon should not be an issue.

The evaluation order can be found on the next tab.

The most selective ones should come earlier than the others.


Hi Holger,

Checked with the evaluation order also.

When compared with the working one, did not find any difference.

Also, attaching the scree shot of the page I am getting when logging in using ‘monitoruser’.