Extract Missing Objects?

I’ve identified about 200 missing objects for an application. Turns out they are CONSTRUCT objects, a few subprograms but mostly copycode and data areas. I have specified 1) a new application in NEE as “SYSCST” (since that is where the objects exist), extracted and loaded the objects from/to SYSCST, 2) specified SYSCST as a steplib in the primary application (the one with the missing objects), 3) tried to EXTRACT MISSING OBJECTS (which are still on the Missing Objects report). Nothing is extracted, and the objects are still “missing” in the repository as far as the primary application is concerned. What have I missed?

Need a bit of info on your environment. How was the job submitted?
Basically it runs a Missing Objects report and creates work file 5 with the list of objects missing which is fed into the extract engine.
If you submitted the job via SPoD to z/OS, then there is a fix required (available in NEE621 SP6 shortly). You could submit the job directly on the MF via the online screens to get around that issue.
If not, the check the work file 5 (.IO file) to see if it contains anything.

All of this is done on z/OS – CICS via NATRJE to TSO batch. Simple. I ran the Missing Object report immediately before requesting the “Load Missing Objects” process, to make sure they were still missing, given that I loaded ALL of the missing objects to the NEE repository as the “SYSCST” application (which I had just created), so that I could specify SYSCST as a STEPLIB to my app (which is called AVAS). Do you need to know anything more?

I have a feeling that it might not pick things up from a FNAT library.
If you copy some of the items to a FUSER library, like NEECST - does it work?
Also, some objects may not exist in SOURCE form. If it doesn’t then NEE cannot pick it up.
What there anything in the WORK FILE 5 of the batch job?

In Wk05, I get the list of modules that I expect. However, in the report, I get this:
Missing Objects Extract
Called via Natural 3GL interface
Start of NATURAL Program Objects
End of NATURAL Program Objects
End of Processing 0 Objects
Summary for NATURAL Objects
Total source lines = 0
Total comment lines = 0
Total lines processed = 0
Total source lines expanded = 0
Total comment lines expanded = 0
Total lines processed expanded = 0
End of Summary for NATURAL Objects

As Brian has indicated it is possible that objects will not be picked up from FNAT libraries (e.g., beginning SYS). Have you tried to copy the construct source objects to an FUSER file such as NEECST or CSTSTEP, making this the steplib and reextracting missing objects ?
Alternatively if they are valid missing objects e.g. construct system objects without source you could specify them e.g., CDH* as valid missing objects. They would then not get picked up on the missing objects report.

Well, I have done the following:

  1. Created a new NATURAL library called NEECST
  2. Copied the many missing CONSTRUCT objects to that library (which is in FUSER as opposed to the SYSCST library that was in FNAT)
  3. Created a new application in NEE called NEECST, and extracted the source code and loaded all of it to the Repository
  4. Edited the the preferences of my AVAS application to include the steplib NEECST
  5. Ran the Extract Missing Objects process

Same results – no source code extracted. Any thoughts?

I would suggest going through you’re local Software AG support centre. It might be a problem with the particular version you are running or they may be able to spot a problem with the configuration.

Can’t seem to come up with any configuration issues. Nothing jumps out of the generated JCL that NEE submits; the ###CINI object looks fine. And, as it turns out, the “Extract Missing Objects” process does not work for any application at any time, regardless of whether the STEPLIB is in FUSER or FNAT. The process correctly populates the working list in CMWKF05, and then proceeds to ignore it by not extracting anything. And the job does not throw any errors into CMWKF04 (empty dataset after the job completes). So I guess it’s off to support… Thanks for your help.