Natural SPoD, NEE and security

To start NEE with SPoD under windows there still remains only one opportunity for me :

  1. Start NEE, invoke Natural, connect with the MF environment, log on to SYSNEE and start NEESTART. Then the Mainframe NEE-environment (Terminal emulation) appeared, I made a definition for an application, defined and executed my impacts… But after starting the according batch job the previous defined application itself had been locked. I wanted to see what had been impacted. But I couldn’t resolve this locking. A password was inquired, which I don’t know. It’s not equal to my own Natural password. :?

  2. Sometimes before this, I tried to get NEE results in accordance to SPoD by using the Windows environment. Additionally I made the repository definition by using a dynamic LFILE assignment. But an error came up which formerly had been described in the Knowledge Database under Document ID 612886. As a solution to this error (GENSEL.ERROR LOADING LIBRARIES! 1999) a redone of the Natural INPL had been requested there. But in my test environment this had been certainly done before! :roll:

  3. The only solution for this, which I can think of, lies in security purposes, because SYSNEE has not been defined as a steplib to any application (Natural Lib). And this may be why NEESTART can’t properly be executed :?:

Good afternoon,

Well, it looks like you are having a few configuration problems, so let’s start at the beginning.

When connecting to a SPOD (NDV) environment with NEE, it should not show a terminal emulation.
Basically, the NDV should be defined to utilize Batch tasks (not CICS).
Also, the mapping to the MF environment should contain the apporpriate LFILE 96 (NEE repository) definition.
NEESTART resides in SYSLIBS on the PC. This is a special program known to Natural to run locally even though you are mapped to a MF environment.
The error 1999 returned by NEE under NDV indicates that the NEE M/F INPL has not been completed. During the NEE M/F INPL it loads objects to library SYSLIB on the mainframe. These are called TPUNEE and TPUNEEnn objects.
BTW, the password to remove a locked application is GENRJE01.
If you are looking to use this, then I would also suggest removing the STARTUP program from the NATENG NATPARM module you are using to start NEE on the PC. THis will then start Natural, allow you to map to the environment, and then (from any library) execute NEESTART.
Let me know if the above helps.

Well, I changed the STARTUP entry in NATPARM and then it worked, so I could open a Mainframe Application.
Starting EXTRACT resp. EXTRACT & LOAD caused an error 1006, i.e. NEE1006 PERFORM PTABLE ALLOCATION FAILED. I increased the PTABLE -Parameter from 300 up to 1000, set the NETWORK - Parameter in NATENG.INI to Y (Repository local) and had this result:

Sometimes EXTRACT & LOAD for a remote application is possible, sometimes not. If it is possible, then I even can define impacts and execute them. But at the latest, when I tried to make manual modifications, an error 6223 has been generated, which sometimes even came up after EXTRACT & LOAD, i.e. the LOAD has not been executed. :cry:

In case of a manual modification the changed object was not rewritten to the modification library, even if there was a final message ‘Object xxxx has been modified to library yyyy’.

I am looking for a reason and a solution for that. I cannot find an explanation to error 6223. How to go on ?

Starting Natural with a dynamic deviating LFILE setting for the Mainframe environment and NETWORK=N (Remote Repository) leads to Search Buffer Errors in internal programs SPDAPP-N, REPCTL-N, GEHEXT-N, MFRJEN01. What else additionally I have to do to get access to the remote repository ?

Thanks for help until now, Brian. Hope you or other colleagues can give me support further on.


Can you confirm that the repository is on the mainframe and that you are wishing to use NDV (SPOD)?