Error: java.sql.SQLException: [SoftwareAG][Oracle JDBC Driver][Oracle]ORA-06550: line 29, column 41:

Hi all,
I am getting error while using dbconfigratorui to create tables of webMethods for my new trial installation. Please help me to identify and solve the problem.

Details about the installation of webMethods, and the version of Oracle are as below

  • Windows 10 operating system 64 bit
  • webMethods 10.15 Trial version
  • Oracle Database 21c Express Edition for windows 64 bit
  • for database I am using Pluggable database XEPDB1 and created a separate user for webMethods.

Thanks,
Manish

3 Likes

Share the errors and exceptions as well please.


database type : oracle
database URL : jdbc:wm:oracle://localhost:1521;serviceName=XEPDB1
version : latest

component : Storage
action : create
component : Storage
version : latest
scripts : 2 total
script : 1
file : C:\SoftwareAG\common\db\DCC\Storage\scripts\8.0\oracle\create_0_ora_str_c_ddl_tablespaces.sql
status : executing
error: java.sql.SQLException: [SoftwareAG][Oracle JDBC Driver][Oracle]ORA-06550: line 29, column 41:
PL/SQL: ORA-00942: table or view does not exist
ORA-06550: line 29, column 9:
PL/SQL: SQL Statement ignored
ORA-06550: line 37, column 41:
PL/SQL: ORA-00942: table or view does not exist
ORA-06550: line 37, column 9:
PL/SQL: SQL Statement ignored

Are you using a DBA account or did you get the account and db’s created by them? Looks like your db account doesn’t have enough permission. If you are using a DBA account you need to enter DBA information to the section below and set the usename and password above that. If DBA’s created that for you make sure you have create, update and delete table permissions and uncheck Create database and database user checkbox.

Follow this document for preparing db. You can find oracle preparation steps at page 38.

1 Like

Hi Manish,

I had the same issue, following a course on Udemy and I guess you are following the same as per the database name.

I managed to solve the problem entering the “system” username instead of the “webmuser” username in the “Create tablespaces and database user/Administrator” form. I hope I can continue with the learning and I didn’t messed something up.

PS. Also, I had to disconnect and reconnect the user in SQL developer to see the tables. A simple refresh didn’t help.

Have a nice day,
Magda

3 Likes

Thanks Engin SARLAK,

your suggestion helped me to solve the issue.

1 Like

Yes I did the same, Thanks for your help.

Solved:
The user must be with DBA privilegies. Example:
grant dba to webmuser;

1 Like

Hi Ricardo,

it is not recommended to have dba privileges on the user you are using for the life data for security reasons.

You should have a DBA-User for creating tablespaces and users with proper permissions to create the dedicated content for the newly created users.

Regards,
Holger

1 Like

Yes this solution worked for me too. Thanks for sharing.