Error defining a schema with interactive interface

Hi all,

My friend and I, we develop a web application using Tamino. We have installed Tamino 4.2.1 and every step went OK.

We need to define schemas into tamino. All went ok on my computer but on his, he got errors when defining schemas with Interactive Interface.
The error was 8711, Document not well-formed. Line 1, Column 1 : Invalid document structure.

But when we tried to define the schemas with the schema editor, it went ok.

Except the OS, our computer are slightly the same.

Do you know how we could solve this problem?
I do think that the error might come perhaps from the encoding!


Please provide a copy of the schema at fault.

It would then be easier to investigate the problem/suggest a possible solution.

Here is the schema.

contractXDraft.tsd (32 KB)

I think that I may know what is happening.

I just tried defining the supplied schema into my Tamino using an interactive interface. This worked without a problem.

I then loaded up the schema into an editor. I notice that there are “spurious” characters at the start of the file - visible if use hex edit mode. Possibly these are a UTF-8 encoding of the byte order mark allowed in XML. I have known some XML processors get tripped up this marker.

You may find that removing the offending characters would allow the schema to be defined from within the interactive interface.

I have downloaded an editor with Hex mode for xml file. I have opened the schema. I have problems finding the spurious characters. Are the spurious characters following lines?


If not could you tell me either the poistion or the hex number of the spurious characters.


It is possible that they are introduced by the download.

I see the three hex characters EF BB BF as the first 3 characters in the file.

I have a problem because I can’t see those 3 characters even by downloading the file again. It could be that the application that I use doesn’t show them.

Could you tell me what kind of editor I could use?
Could you also send me a sample or a picture showing me those 3 chars?

Thanks a lot.

I am using UltraEdit32 version 9. I have deselected the option “Auto Dectect UTF-8 Files”.

These characters are the UTF-8 encoding of the “byte order mark” (BOM). If you search Google for “EF BB BF” you should see related pages.

Applications that understand the BOM automatically hide it (e.g. XMLSpy, Notepad).

I have found those characters. My previous application was understanding the BOM automatically.
Now i have to find which program has inserted those characters.