load xml file using interactive interface

Hello:
I meet such error when I use interactive interface to load a simple xml file.(see the xml and xsd file in the attchment).

<?xml version="1.0" encoding="iso-8859-1" ?>
- <ino:response xmlns:ino=“http://namespaces.softwareag.com/tamino/response2” xmlns:xql=“http://metalab.unc.edu/xql/”>
- <ino:message ino:returnvalue=“0”>
ino:messagelinedocument processing started</ino:messageline>
</ino:message>
- <ino:message ino:returnvalue=“8814”>
<ino:messagetext ino:code=“INOXRE8814”>Element/attribute name not found</ino:messagetext>
ino:messagelineLine 3, Column 1: Element name = root</ino:messageline>
</ino:message>
</ino:response>
test.xml (288 Bytes)

since I can only attach one file one time,I attach the xsd this time.
test.xsd (957 Bytes)

I assume you didn’t define a Tamino Schema first.

If you are using Tamino 3.1 you use the Schema Editor to produce a Tamino TSD3 Schema and define it in Tamino. Essentially a TSD3 Schema is an annotated W3C Schema.

I did this and tried to load the data. I got an error because the schema doesn’t define the xsi namespace. I then remove the xsi declaration and
attribute from the root node od the INSTANCE and it loads successfully.

If youare using Tamino 2.3 you will have to create a TSD2 schema.

Before I we go any furthe I would like to know which version of Tamino you are using and whether the xsi hint is used by the application.

Whic

I use Tamino 3.1.1
I produce a .tsd file using schema editor,and then I define it using interactive interface,it successful.
But when I process the .xml file,it still show the same error as above.(I remove all the attribute of root node,including xsi)

Are you 100% sure that you set the collection correctly in the TII when you do the load?