Schema definition error

Hi all,

I need to trigger functions in Tamino for my work. I was following the intructions in “JAVA Trigger Sample”. At step 2 when you need to define the schema "TriggerJ_schema.tsd, instead of the successful message I get the following message:

    This XML file does not appear to have any style information associated with it. The document tree is shown below.





Not a valid request
Value of command _DEFINE must be text.

I’m using Tamino Server 4.4.1

Thanks for the attention

The error response you

Thanks for replying.

I’m sorry last time I didn’t post the correct return message.

This is the correct version. I don’t know everytime I post my message, after submitting, the forum cut off its content.

My ino:returnvalue = “8552”
and ino:messagetext ino:code = “INOXME8552” and the messagetext is
Value of command _DEFINE must be text.

I’m sure I have the connection to the server since I used the Diagnose function of Tamino Interactive Interface.

From this thread http://tech.forums.softwareag.com/viewtopic.php?p=34978&sid=8c59155f87f59aebffe0fc0dc838b5e1

I think it seems the Define form did not read the content my schema file.

I tried to use SoftwareAG Tamino X-Plorer to define my schema. It worked wells. But since I don’t follow exactly the steps in the README for JavaTrigger example so there’s no SXSJSample schema defined in collection SXSJSample when you defineTriggerJ_schema.tsd

Any ideas to overcome this? Thanks you for reading my troublesome post ::slight_smile:

Hi,

it looks the browser sends the content of the schema file (TriggerJ_schema.tsd) as a mime/content type which Tamino does not perceive as text. There are two approaches to solve this:

(1) workaround: rename the schema file to use another extension instead of .tsd, e.g. .txt or .xml
(2) towards a real solution: activate Tamino’s XML request log or use an HTTP sniffer and check the mimetype associated to the DEFINE command.

If you are using IE it is likely that the content type being sent to Tamino is based on the file extension and applications associated to the extension. When working under Windows: which type of file is given for .tsd in Windows explorer?

Best regards
Uli