Error Adding MWS to Deployer

Hi, When I try to connect to a MWS server from Deployer I recieve the following error:

Error connecting to server: Plugin System Name: local, Plugin Type: MWS, Service: “Ping” neither returned version number nor returned any fault. Make sure that you are trying to connect to correct plug-in server which is accessible with the supported credentials and plug-in server is up and running.

All the info is correct and the MWS is up. Am I missing something?

Thanks

Please check all these options related to 822 env based on the error you were getting:

Empower Resolution:

This error can be caused by many things:

  • Incorrect credential configured.
  • Target BPM Server is not running.
  • Target BPM Server’s WmDesigner package is not loaded properly or corrupted.

Also
https://empower.softwareag.com/sl24sec/SecuredServices/KCFullTextASP/viewing/view.asp?KEY=087190-16547989&DSN=PIVOTAL&DST=TCD&HL=1&QUERY=trying|connect|correct|plug-in|server&SessionID=202157194

Hi,

The server is running and my credentials are good. I have tried with my personal ID and the Administrator account.

To your third point, how do I check what packages are deployed in MWS?

Thanks,
Alex

No that point 3 applies for BPM models deployment not for MWS specific.

Do you have any the DEP_822 fixes installed already can you check?

Please open a ticket with SAG support if the issue still persists.

Hello rmg,

We are seeing the same error on our environment. How do we install the DEP_822 fixes? We tried downloading using the UpdateManager on the command line of the OS but it doesn’t seem to pick up these fixes. Can you help?

Thanks!

You should have internet connectivity through proxy in your Unix system, and also you would need empower credentials. Only then you can download fixes, and install it using SUM.

Please refer documentation.

-Senthil

Thanks Senthil.
The system has connectivity to the Internet; We’ve used the Update Manager script under SUM/ to download to download the fixes but we don’t see the above mentioned fix applied. Is there a chance a newer version was released and is a cumulative fix?
Appreciate the assistance.

Krishna,

What DEP fixes currently you have and expecting?

Latest I have is DEP_8.2_SP2_Fix9

HTH,
RMG

Thanks rmg
This is the patch we have installed (using UpdateManagerCMD.sh)

Fix 8.2.2.0005-1014

We do not see any patches later/newer than this, if these aren’t the latest.

I have attached screenshots of 2 environments we have here,
a) Environment A - that is built by the Webmethods team
b) Environment B - that we built

On Environment A, the patch DEP_8.2_SP2_Fix8 was applied and listed as shown. Whereas we do not see the same on Environment B.

Appreciate your help.


So are you planning to install any fixes on Environment B as well?

which environment is working vs not working just to understand clearly?

Did you contact SAG support to open SI on this?

HTH,
RMg

Hi rmg,

We got it resolved.
The issue was we were installing the updates to /SUM which the updatemanager.cmd defaults to. We changed this to /IS for Integration server, /OPT for optimize server etc…

Thanks for your help!

huh! good catch! :smiley: