EDIINT Stucked in SendMsg:WAITMDN Status

Hi -

We are seeing alot of outbound EDI documents trapped in SendMsg:WAITMDN Status in TN/MWS for its EDIINT. But when we check the Activity Log, processing was already completed (Processing Complete) but on the Transaction screen, USER STATUS still showing as SendMsg:WAITMDN.

Any idea how we can complete processing and move the EDIINT status as SendMsg:DONE?

Did you make sure proper EDIINT MDN was received back and sync with the request EDIINT message?

Please check if the MDN received back to the TN for the original request sent.


Thanks for the response. I will further check on this. Additional question though, in the event that a MDN was not received back - how are we going to abort or moved the processing to display either SendMsg:Done or SendMsg:Abort/Failed?

OK please check more…

There is no other way other than you may try update status using tn.doc:changeStatus…but this isn’t a good practice for changing EDIINT statuses.


The status of SendMsg:WAITMDN is a good indication that the MDN is not received. depends on your need, you can scan document with such status and trigger redelivery or other options if it’s on such status too long.

I did check and we received the MDN back. The Delivery Processing even suggests its complete but still the UserStatus is still stucked in SendMsg:WAITMDN? Any idea what might occur?

Strage…Are you sure the activity log shows no error on the original EDIINT request that was sent to TP?

Normally it should correlate the request and synchronous MDN if your activity log shows correctly…

What is your EDIINT module version?


in MDN, you should see:
Original-Message-ID: ******
it’s used for associating the MDN back to the original AS2 message.
You can check if it’s matching the original message ID.
If not, the client’s system is not returning proper MDN.
if yes, you need to debug through the MDN handling service to find out why it’s not finding the matching document.

Yes when I said check more details on the Activity Log its the same as Tong Wang said…

Please check it and confirm the thread back.