Different responses with different versions of communicator


I am trying to pull some data from a Natural Subprogram. The data is available in the mainframes. I created the XMM from the IDL file using EntireX Workbench version for windows. I tried invoking the service from Workbench by passing request XML.
In got a valid response from the service, but some part of it (a string array) is missing.
I had another version of communicator v7.1.1.50a in which I generated the XMM and tried hitting the service. However in this case i was lucky enough to get that some part of response which was missing and not completely.

I could not visualize why this difference occurs in both these versions. The bottom line is that I have a Natural service, but eventhough i have two versions of communicator with me, I am not able to consume it fully.

Any help in this regard will be of great use to me as I am spending days and nights with this issue. :frowning:

Thank you so much,

There is a newer patch for v7.2.1 (pl50) and some hotfixes available in ServLine24 that address some issues in XML services.

If these patches don’t help, try turning on the trace in the EntireX XML Servlet (which I’m guessing is what you are using) - copy the etc\entirex.trace.standard file to your webapps \entirex directory as entirex.trace.properties. Edit the properties file to adjust the trace level and set the output destination to FILE. Restart your webapplication and see what the trace shows you.