How to configure the natural client profile

Hello, I am trying to consume a web service from natural.

I am using entirex 7.2.1 /50 and natural V 6.1.1 Pl 15

And I have done the next steps:

  1. Import the WSDL
  2. Generated the IDL and mappings (using EntrieX Workbench)
  3. Set the properties for the IDL to specify the Broker ID, port, RPC Server Class, Name and Type.
  4. Modifed as required.
  5. Modified entirex.xml.runtime.configuration.xml to set the Broker ID, Server Address, Target Server and xmm name
  6. Defined and started a local Broker using SMH
  7. Modified the bat file used to start the RPC server.
  8. Ran the bat file to start the RPC server
    11. Created a Natural client Profile.
  9. Started Natural using the profile created, wrote a short program that issues a CALLNAT to the web service and ran the program.

The problem is when I try to run the program I get: “NAT0037 Name missing or specified incorrectly.”

The parameters I am using in Natural are:

RPC(MAXBUFF=28, AUTORPC=ON, COMPR=2, SRVNAME=server-name,SRVNODE=broker-name)


Now I found how to do it with sysrpc, now I have a NAT0998 Internal Error 20000086 Receive fault document.

I found a technical tip in servline document ID: 544185, the resolution is include SOAPAction tag in xmm file but I don’t know how to do it.

I believe the document is indicating that the WSDL to XMM import will be changed. You should update to a current version of EntireX and try again.

In the meantime, you can turn on tracing to see the SOAP fault document - look for entirex.trace.standard and rename to, and edit the properties in it. I typically use:


Restart your xmlrpcserver, recreate the problem then look in the log file (exx.sdk.xml.runtime.log) for the documents.