Designer - Server certificate rejected by ChainVerifier

Hello everyone.

I recently updated my Software AG products in my workstation using Update Manager.

But, after the update, I started to receive the following error when I try to connect to my Integration Server inside the Designer:

Connection failed for myIsHost:5200 (Server certificate rejected by ChainVerifier)
Server certificate rejected by ChainVerifier

All of the certificates in our Integration Server are valid and didn’t expire yet.

I tried to create a new keystore and truststore with the most recent ones in the IS and I set a new HTTPs port that uses them. Still, no success.

Please, what should I do to fix this issue inside Designer? I can only connect to my IS via HTTP.

Thank you

Follow these steps (from Designer online help):

Configuring SSL Connections in Designer

Use the following procedure to configure a Secure Sockets Layer (SSL) connection in Software AG Designer.

For more information about Java SSL configurations, see the JSSE Reference Guide in the Java SE documentation.

To configure an SSL connection

  1. Locate the following file in your Designer installation:

Software AG_directory \Designer\eclipse\configuration\config.ini

  1. Open the file in a text editor.

  2. Add the following lines to the file: file path

where truststore file path is the path to the server truststore in your file system. For example:\keystore\localhost.jks

Note: Be sure to use the correct separators when specifying the path to the truststore file. For example: C:\ file type

where truststore file type is the type of truststore file that the server supports. For example:

  1. Save the file and restart Designer.
1 Like

Hello Dear @Tong_Wang .

Thank you for your answer with the config.ini change. But, unfortunately, it didn’t solve the issue :frowning_face:

I set the properties that the help suggested as follows:\SoftwareAG\jvm\jvm\jre\lib\security\integrationserver.jks

But I’m still getting the same error. This ‘.jks’ file it’s the same used in our Integration Server.

Please, is there anything else that I must check?

Thank you.

If you are not worried about connection trust and risk of accepting all certificate, paste below line in config.ini and restart designer. This will accept all certificate chain.


Or else prove your current config.ini to check.

1 Like

Hello @Farid_Yar_Khan

You solution, unfortunately, did not work. :frowning_face:

My “eclipse.ini” file inside “C:\SoftwareAG\Designer\eclipse” path has the following configuration:

# Launch configuration settings for Software AG Designer
# For information, refer to the Software AG Designer documentation, available as online help in Designer itself or on the Software AG documentation website.
# The following option is only applicable to Java 7 and earlier 
# --launcher.XXMaxPermSize 
# 256m

I also tried adding the following lines, but no success yet:


Thank you.

Did you tried adding them to the Software AG_directory \Designer\eclipse\configuration\config.ini file? Because I do see that you have added them to the eclipse.ini file, could you please confirm?

Hello @Renan_Lopes1

I appears the setting -Dtrust_all_cert=true is not working since it is disabled in few VM version. However, about the argument Please try double back slashed instead of single and try again.

I am assuming you have kept you truststore at this location. Generally locationis \common\conf