Deployment Not Complete Because of Initiating Deploy operation on node ACLs

WmDeployer, Integration Server used and 10.11 level:

We are deploying partial build using WmDeployer but its not getting completed.
I can see in progress report that its initiating Node ACLs deploy operation but it’s not getting till done.

When compared to other progress reports which are getting successful, there we can see both lines.
2024-05-13 13:35:53 AST Initiating Deploy operation on node ACLs (target server : )
2024-05-13 13:37:35 AST Done with the Deploy operation on node ACLs.

But on same server but different build its showing only initiating.

2024-05-13 13:21:32 AST Initiating Deploy operation on node ACLs (target server : )
2024-05-13 13:24:38 AST Completed deployment of myDeployment
2024-05-13 13:24:38 AST Completed generating Progress Report for the Deploy operation.

Even though its showing completed deployment but node deployment is not getting done and we never see Deployment report on Deploy page even after waiting for 2 hours.

Can anyone help to under what could be stopping this to get deployed.

Thanks

Hi Rohit,

when deploying nodes, which are secured by ACLs, remember to have the user in the ACL on target node, which is used to run the Deployer. Otherwise the ACLs cannot be assigned correctly to the nodes during deployment.

Can you check what is the difference between these two builds?
I assume, that one of them contains nodes, which are secured by ACLs, while the other does not contain such nodes.

Please check the affected server logs for messages related to the deployments.

Regards,
Holger

Hi Holger,

Thank you for your response, it worked now.
There was one corrupted Nodes ACL file for JDBC connections package. Worked after taking separate build for this package.

1 Like