Creating A Dirctory Service in MWS from a DB

Hello All ,

I m trying to create a Directory Service form a Oracle DB , I created a DataSource and Filled in All Attributes and queries as mentioned in Documentation . I didnot get any error during this Process . ( i searched in logs too )

but when i m trying to Search for Users in Db i m not able to find them in Search Results.

can you please let me know how to debug that my directory service is setup right

any help Appreciated .

Thanks

While searching for the users, did you select correct directory service from the “Directory Service” Dropdown?

yes I did ,

Hi I am facing a similar issue.
I have created a directory service pointing an sql db.It has a table named users with fields UserId,GoupName and Password.Now I have defined all the User attributes to UserId and GroupAttributes to GroupName.
Now in the Query Lookup User By ID (required) I have gvien the query select * from USERs where USERID=’{uid}’.
For this I am getting an error "

[POP.012.0006.wm_xt_dbdirsvc] An error occured executing the SQL query: “select * from USERMEMBERSHIP where USERID=’{uid}’”. Please type a valid query and try again."

Can any body please help…!!

Hi Ravisr

Do you have any mixed-case column names in your database tables? That can be worth watching out for (and avoiding).

Just try ${uid} and see

Facing same issue “Please type a valid query and try again”

Have created a simple DB table:

CREATE TABLE [user_](
[ID] nchar NULL,
[EMAIL] nchar NULL,
[FIRST_NAME] nchar NULL,
[LAST_NAME] nchar NULL,
[LOGIN] nchar NULL,
)

and trying to use the below query

SELECT * FROM user_ a WHERE a.id = {uid}

tried with ${uid} also, still not working.

Can somebody please put some light on this?

Are there any solutions to the {uid} error?
If i fill in the Query
" SELECT * FROM users WHERE id=‘1’ "
it works fine but with
"… id=’{uid}’
it throws the error :confused:
Hint: Working with MS Sql in background